1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

1997 GMC Suburban - No 4 Wheel Drive

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by mdmccool, Jan 3, 2013.

  1. mdmccool

    mdmccool New Member

    Hi Guys,

    New to the forum and I have a few questions I'm hoping someone might be able to help me with.

    I recently picked-up a 1997 GMC Suburban K1500 and the electronic 4WD does not work. Previous owner is a friend and said the dealer told her the transfer case motor was bad. Not trusting the local dealer (they have a bad rap) I figured I'd do some troubleshooting before I start replacing parts. I have the GM service manuals and went through the entire troubleshooting tables to no avail. No codes stored in the 4WD switch module. Fuses good.

    The truck will not shift into 4WD - when the 4 HI or LOW button is pushed, the appropriate button blinks for a few seconds, I can hear a relay in the dash fuse panel click, I can hear the motor on the transfer case run, and it just goes back to 2WD.

    I pulled apart the transfer case motor and all seems fine - it is free and operated on +12V and -12V in opposite directions. I can hear it "work" when the 4 HI or LO button is pressed. Also checked front axle actuator - seems to work fine although maybe a little slow. I do get a brief pulse of 12V from the TC switch at the actuator when the TC motor is trying to shift to 4WD. This indicates to me that the motor is working, but perhaps it is not stopping at the correct intervals???

    Could the module be bad behind the switch panel? I hate "shot-gunning" parts as it is usually a waste of money. Trying to narrow this thing down.

    Any ideas would be appreciated!

    Matt
  2. Conlan Rose

    Conlan Rose Active Member 2 Years 1000 Posts

    Well if it isn't engaging then obviously something is preventing it from activating all the way. Have you checked to make sure the front diff is engaging because it if doesn't then the TC wont complete the shift.
  3. mdmccool

    mdmccool New Member

    Conlan - Thanks for the reply. The front diff is not locking - I don't think it has a chance to. When the 4WD button is pressed, and the motor tries to shift the TC - I get a brief pulse of 12V at the front actuator. The system cycles back to 2WD so fast the front doesn't have a chance to engage. I have also read when guys have problems with the front actuator, the system says you are in 4WD but you soon discover otherwise.

    Matt
  4. Pikey

    Pikey Active Member Staff Member 2 Years ROTM Winner 1000 Posts

    With my 95 the 4x4 indicator would not show 4x4 unless the front actuator was engaged. I had a cable actuated front actuator. So, I would put the tcase in 4x4 and not engage the diff. It would only show 2x4 until I pulled the handle. So, I do not think that the indicator would falsely show 4x4 unless the front diff was actuated.
  5. Conlan Rose

    Conlan Rose Active Member 2 Years 1000 Posts

    Have you tried engaging it on the move. You can engage 4hi while moving and with out shifting out of drive. The problem with this era of truck is they don't have extensive 4wd codes or electronics. The system is super simple just actuators replacing manual components.
  6. vncj96

    vncj96 Epic Member 5+ Years 1000 Posts

    You can sit and guess and replace a lot of parts before you get the right one, many times its the switch itself that doesn't work, any GM dealership can test the 4wd system cheaply and may even waive the fee as long as you get it fixed by them, I know of some that will.
  7. dmtibbs

    dmtibbs New Member

    Encoder Motor

    I had a similar problem as part of my "stuck in 4wd" adventure. I know your problem is the opposite but what I found could also cause your problem. Did the problem start as intermittent and slowly become permanent? Mine did. I found that the small orange wire on the encoder motor plug had corroded and broken. This wire supplies 10V+ to release the encoder motor brake. The small brown wire is ground supplied by the TCCM. If either wire is broken, the brake will not release. My motor would run while off the transfer case even though the brake wasn't released but it ran pretty slowly and got warm. When installed on the TC, it didn't have enough umph to overcome the brake and rotate the shaft to switch the TC both. My wire was broken right at the plug and I had to remove the plug from it's hanger to see the back side of it. After the wire was repaired, the motor almost snaps to change position. I think the TCCM needs the signal from the encoder that the TC has shifted to 4WD before it will engage the front axle actuator. My second problem, related, was self induced. I had plugged in the wiring to the encoder part of the motor crooked and bent two of the pins. This made my truck act exactly like yours except that I had a service 4wd light on the cluster. This was after I repaired the broken wire and I was about to start throwing things. Hope this helps. I have a 99 Suburban, a little different system but same operating principal. Electric shift TC, TCCM, encoder motor, axle actuator. Maybe check fuses too. There should be two. One for the encoder motor, I think the fuse cover calls this one the transfer case fuse (#2 in my '99). The other is called the 4wd fuse (#24 in mine). Good luck.
  8. bigblacktruck

    bigblacktruck New Member

    Check electrical connections

    Had problem with 4wd on my 97 K1500- pushed 4Hi & light would blink, heard things whirring/clicking but would never indicate 'engaged'. Of course, found this out when 4wd was needed & had to resort to ropes & come-alongs. Turns out the transmission fluid that has been leaking out of tranny case crack (2nd time in 3 mos on rebuilts, but that's another story) had gotten into the contacts/connectors & after a complete bath with brake cleaner (5 cans on underside of vehicle), the 4x4 started working again- engaged properly, etc. May want to check for fluid invasion- first failure of the trans case/fluid leak had caused a brand new O2 sensor to fail as well- cleaning of the connection solved.

Share This Page