1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

1998 Chevy 4x4 w/5.7 w/PO300 Code.

Discussion in 'Chevy C/K Truck Forum' started by metal77, Oct 28, 2011.

  1. metal77

    metal77 New Member

    Put New Spark Plugs,wires,disb,rotor. Doesnt Idle Very Good, Iwas Pulling a Camper 2-Weeks Ago Engine Service Light Came On Almost Home An Engine Was not runnig good, scaner Said # 6 Cy Misfired So Put New Plugs Wires Etc Need Help,put scaner back on an said PO300 Code
  2. 99'HEARTBEAT

    99'HEARTBEAT Moderator Staff Member Platinum Contributor 1000 Posts 100 Posts



    Trouble Code.....P0300.......is a Random Mis-Fire....but it Doesn't tell you Specifically which Cyl(s) is/are Mis-firing, nor why.....

    What Causes a Trouble Code P03
    00.......may mean that one or more of the following has happened:
    • Faulty spark plugs or wires
    • Faulty coil
    • Faulty oxygen sensor(s)
    • Faulty fuel injector(s)
    • Burned exhaust valve
    • Faulty catalytic converter(s)
    • Stuck/blocked EGR valve / passages
    • Faulty camshaft position sensor
    • Defective computer
    What Brand of Spark Plugs did you installed/go with??...On the items above I would look at the Plugs and Wires first and foremost, as you just installed them.


    Last edited: Oct 28, 2011
  3. metal77

    metal77 New Member

    Put In Delco P spark Plugs
  4. murdog94

    murdog94 New Member 1000 Posts 100 Posts

    I would put some decent money that you have a bad Fuel pressure regulator expecially by getting a number6 misfire first. the best way to check is to remove the TB and look into the intake, you should not smell raw fuel and if you do then you have found your issue.
  5. maxpayne23

    maxpayne23 New Member

    I think you may have answered my question. I have a 99 with the same issues. as well as a bank 2 sensor 2 fault.

Share This Page