1999 Suburban steering noise, but not a clunk or whine...

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by bettingsumo, Sep 5, 2013.

  1. bettingsumo

    bettingsumo New Member

    Hello everyone,

    I just acquired a 1999 Chevy Suburban K2500 with the 7.4L engine. Very happy to be driving this beast, but there are a few nagging issue that brought me here to try and learn from everyone. I have searched all over the forum for an answer to my steering column noise, but everything seems to refer to a clunk, whine, or moaning whale.

    I don't have any of those noises. My steering noise sounds more like a scrape that repeats at regular intervals when I turn the steering wheel. I really only notice it when I am turning the wheels fully in a parking lot, not while driving on the street.

    I don't know how else to describe it, but I took the following video so you can hear what I am talking about.

    http://youtu.be/tITuHIKU-Bc

    This was taken while parked so I am just quickly turning the steering wheel from side to side, but if I were to fully rotate you would hear the noise repeating regularly like "scrape....scrape....scrape....scrape....scrape" all the way to lock.

    Thanks for any help you can give.
     
  2. Pikey

    Pikey Moderator Staff Member 3 Years ROTM Winner 1000 Posts

    Welcome to GMTC! It may just be the angle of the camera, but is that boot going thru the firewall not seated properly? You could always try spraying some lube on that area and up toward the bearing located in the column. I had a friends vehicle with a similar noise. I ended up pulling the airbag and spraying a ton of lube down into the steering column. It lubricated the top and bottom bearing in the column and the noise stopped. You may also want to check plastic column covers near the back of the steering wheel. I have seen people remove them for one reason or another and not be able to get them realigned correctly causing them to rub on the back of the wheel.
     
  3. bettingsumo

    bettingsumo New Member

    Ya, the boot does look funny, but it is seated properly. It is just the padding around it that makes it look strange. I am going to try your suggestion of spraying some lube up there and see if that helps.
     

Share This Page

Newest Gallery Photos