1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

1st gear shifting problems.

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by Stellarex, Oct 1, 2009.

  1. Stellarex

    Stellarex New Member

    Hey everyone, new to the forums but not new to these trucks.
    I've owned a 98, 99, and now my 03 Silverado, all 1500's with the 5.3L engine.

    Now on to my problem.

    My 03 has just hit 110k miles and the transmission is starting to feel sloppy going from first gear. After the initial take off it will hesitate for a second before shifting to second gear. Its almost like the computer is not telling it to shift at the right RPM's. This is the only gear that this happens in which leads me to believe that its not that the transmission is going out, but that something is wrong with it.

    The fluid has been flushed and filled early in 2009 (around 20k miles ago).

    I'd really rather not have to replace the entire transmission, just wondering if anyone else has has a problem like this before.

    Thanks for any and all the help!
  2. Jimmiee

    Jimmiee Epic Member 5+ Years 1000 Posts

    Welcome to the Club! Your problem could be a number of things like a hanging shift valve, broken accumulator spring or TV Valve. I would start by checking the TV cable. Make sure it pulls in and out smoothly. This is what controls the shifts on your transmission. If the cable is OK you may want to pull the pan and inspect the filter. Make sure it's not full of debris. If that looks good then remove and inspect the accumulator which is bolted on the bottom of the trans next to the valve body.

Share This Page