1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

2000 jimmy po146

Discussion in 'General Chevy & GM Tech Questions' started by harleybuda, Oct 16, 2011.

  1. harleybuda

    harleybuda New Member

    i am getting a po146 code on my wifes jimmy which no activity detected bank 1 sensor 3 my problem is i do not have a sensor 3 ??? i have 1 on each pipe off the manifolds and 1 down stream past the cat so the most i believe i could have would be bank 1 sensor 2 i am stumped and i have replaced the o2 sensor downstream
  2. 99'HEARTBEAT

    99'HEARTBEAT Moderator Staff Member ROTM Winner Platinum Contributor 1000 Posts

    The 02 Sensor Downstream, after the Cat......is the number 3 Sensor and for a P0146,

    Potential causes of an Trouble code P0146 include:


    • Bad Bank 1, Position 3, 02 Sensor
    • Wiring problem, melted harness, broken connectors, etc.
    • Bad PCM



  3. murdog94

    murdog94 New Member 1000 Posts

    That is it. most likely a broken wire somewhere
  4. harleybuda

    harleybuda New Member

    would you know which wire or wires it could be and could i just run a new one i have traced them back and they don't seem to be damaged and i have not been able to locate a diagram that shows the o2 sensor down stream i have tested with a multi meter and everything tests ok

Share This Page