1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

2000 Yukon with 6.0L engine and ignition codes P0351

Discussion in 'GM Powertrain' started by Crawdaddy, Aug 11, 2013.

  1. Crawdaddy

    Crawdaddy Thread Killer Extraordinaire Staff Member 5+ Years 1000 Posts Platinum Contributor

    My cousin recently bought a 2000 GMC Yukon with the 6.0L engine. After running the engine for about 30 minutes, the computer throws codes P0351-P0358. It looks like they're codes for circuit malfunctions on all 8 cylinders. The engine runs fine and doesn't seem to misfire or anything. The previous owner said he changed the coils and my cousin has already changed the plugs and wires. There was predictably no change.

    Logic says the issue shares some commonality since it's all 8 coils and each coil fires 1 cylinder. Commonalities I see are the grounds, the hot fuse, and the computer. Even the signals from the computer to the coils take 2 different bulkhead connectors to get to each bank of coils.

    Any ideas?
  2. Crawdaddy

    Crawdaddy Thread Killer Extraordinaire Staff Member 5+ Years 1000 Posts Platinum Contributor

    We still have no resolution to this. He brought it to a technician to take a look, and the tech couldn't find anything wrong that would cause the light to come on. I think the ground strap to the block still needs to be checked, but otherwise we're clueless on this.

Share This Page