1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

2001 1500 4x4 problems

Discussion in 'GM Powertrain' started by powerlab, Jan 26, 2011.

  1. powerlab

    powerlab New Member

    What i have going on is when i hit the 4hi button it blinks 4 or 5 times then goes back to 2hi and blinks 4 or 5 times then stays solid.My 4 wheel drive is not working.When i hit the 4 hi button i can hear the transfer case motor ingage then disingage when it goes back to 2 hi. I have replaced the front actuator on the axle...the transfer case motor and the switch on the dask....the fluid looks good in the transfer case also.Ive heard theres a sensor on the case it might be or the transfer case control module.If any of u guys have had this problem please help....thanks.
     
  2. scchevy

    scchevy New Member

    same thing

    My 2002 is doing pretty much the same thing. The lights flash, it sounds like the actuator in the transfer case is trying to engage, then I get the service four wheel drive light. It will go off, then the 4 hi light comes on, but I'm running in 2wh. I also replaced the dash switch, still broke. I look forward to hearing some help with this problem.
     
  3. DAREDEVIL

    DAREDEVIL Rockstar 4 Years 1000 Posts

    are you guys doing it in neutral ???? because otherwise it won't work...just sayin
     
  4. scchevy

    scchevy New Member

    I made sure I'm in neutral. I've had it at a shop, the mechanic checked everything, he even called another guy to come over and look at it. He said from underneath he could make it engage, that it didn't seem to be getting the voltage. They thought it was in the pushbutton switch so I bought a new one and replaced it, but it didn't help. Powerlab, have you checked the control module behind the instrument cluster? It seems like you have tried everything but that.
     
  5. DAREDEVIL

    DAREDEVIL Rockstar 4 Years 1000 Posts

    maybe the shift seliniod is bad on the tranny ??? or the wire is broken somewhere between the button and seliniod ?
     
  6. powerlab

    powerlab New Member

    ok guys...i fixed it...heres what happened...the transfer case module was bad...one of the plugs that pluged into it came right out.The soulders went bad and the plug fell out. I took the box apart and soldered the plug back on and works like a charm.....
     

Share This Page