1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

2001 Silverado 1500 trouble code P0118 and P0453 and temp guage doesnt work

Discussion in 'GM Powertrain' started by N5856Z, Nov 9, 2010.

  1. N5856Z

    N5856Z New Member

    I have a 01 silverado 1500 with a 4.8L having some trouble.
    I get codes P0118 and P0453, when I clear codes they come right back on.
    changed fuel pump and ECT sensor recently after temp guage quit working.
    sometimes when driving on rough roads or stopping abruptly the engine will quit but then starts up and runs ok.
    any ideas
    Thanks
    Jon
  2. 99'HEARTBEAT

    99'HEARTBEAT Moderator Staff Member ROTM Winner Platinum Contributor 1000 Posts

    For the Code...P0118......may mean that one or more of the following has happened:
    • A bad connection at the sensor
    • An open in the ground circuit between the ECT sensor and the PCM
    • A short in the voltage feed between the sensor and the PCM
    • A bad PCM (less likely)
    • A bad temperature sensor (shorted internally)
    For the Code...P0453.....may mean that one or more of the following has happened:
    • Open on FTP sensor signal wire
    • Short to voltage on FTP sensor signal wire
    • Bad FTP sensor
    • Abnormally high pressure in fuel tank due to blockage in EVAP purge hoses or overfilled tank
    • Loose/damaged FTP sensor connector
    • Loss of ground to the sensor
  3. N5856Z

    N5856Z New Member

    ok I will look into that. just thought I share some more info.
    I pulled the connector to the ECT and checked voltage with key on and I get 12 volts, I checked the other wire that should go to ground or signal return to the PCM I get nothing. I'm thinking that the ground wire or return wire is open, would need to pull the connector off the PCM and check continuity on those wires. not sure where the PCM is located the haynes manual isnt real clear on where the PCM is located.
    also if I clear the codes the P0118 comes right back on after 30 seconds.
    I cleared the codes this morning before I went to work, the MIL light came on before I could back down the driveway. Tonite leaving work I cleared the codes and the MIL light didnt come on at all, but the P0118 code is there now. I believe the P0453 code is what is turning on the MIL light.
  4. N5856Z

    N5856Z New Member

    I traced some wires tonite on the ECT circuit and found the connector at the ECT is intermittent. I found I have continuity from the ECT plug(yellow wire) to pin 74 on blue connector of PCM, but not sure what pin the ground (gray or tan wire) goes to on the PCM. where can I get a new connector for the ECT at?
  5. N5856Z

    N5856Z New Member

    ok I solved my ECT code P0118, ended up being a bad connector at the ECT sensor.
    I still get the P0453 code FTP sensor.
    I looked at my manual at it says the FTP sensor is in the fuel tank pump module. I replaced that pump about a month or so ago, and really dont feel like pulling the bed off to get to the fuel pump again. anyone have the wiring diagram for the FTP sensor and what pins it goes to on the PCM.

Share This Page