1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

2001 Suburban 4wd issue

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by cbe295, Jan 20, 2013.

  1. cbe295

    cbe295 New Member

    I have an 01 suburban 1500 4x4. The 4 wheel drive is push button. It's not working. I push the 4 hi or 4 low or auto and the lights switch to whatever button I push. Also, I can hear the actuator working. I have no idea what it could be. I heard if your abs light is on it won't engage so I got that problem out of the way and it's still not working. Any ideas? Thanks.
  2. Pikey

    Pikey Moderator Staff Member ROTM Winner 1000 Posts

    check the front actuator. Unscrew it from the axle and put it in 4x4. See if the piston moves out.
  3. cbe295

    cbe295 New Member

    I tried that. The piston moves out. Would the 4wd not work if there wasn't any fluid in the transfer case?
  4. Pikey

    Pikey Moderator Staff Member ROTM Winner 1000 Posts

    It may or may not work. It may work for a short time. If yours is empty that may be why it is stuck in 4x4
  5. cbe295

    cbe295 New Member

    It's full of fluid. It's not engaging into 4x4. It's stuck in 2wd
  6. Kady

    Kady New Member

    Maybe its the switch on the dash?>?
  7. cbe295

    cbe295 New Member

    As soon as I get money I will buy one and put it in. I got told from a guy that works at advance auto that it could be the switch or the transfer case motor.
  8. cbe295

    cbe295 New Member

    So i put a new switch in and the 4wd still isnt working. Me and a buddy jacked the truck up and hit the 4wd button and could still spin the tires so the front end wasnt locking in.
  9. cbe295

    cbe295 New Member

    I had to rebuild the front diff. The washer type thing in there got pushed around and messed eveything up. Thanks for the help though.

Share This Page