1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

2001 Suburban Gas Gauge, 4x4 switch and rear wipers not working

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by MrEarp, Aug 22, 2012.

  1. MrEarp

    MrEarp New Member

    This is strange..

    2 weeks ago we replaced the fuel pump in my truck. So yesterday I'm driving down the road (With a FULL tank of gas) and Whammo the low fuel light pops on and the gas gauge goes to empty.

    So I pulled over, turned off the truck and turned it back on. Needle came back up. Went through this process 3 times.. Finally it stopped on Empty.

    The 4x4 Switch is not lit up, and the rear wipers will not turn on either.

    Any ideas?
  2. Pikey

    Pikey Moderator Staff Member 2 Years ROTM Winner 1000 Posts

    As far as the 4x4 switch goes, I would start looking at connections on or around the T-case. Maybe one was knocked loose during the fuel pump install. I would actually check all the connections relater to your issues. They may have gone together ok, but there can be corrosion that is not letting the connections work.

Share This Page