Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

2002 avalanch stuck in 4 hi

Discussion in 'GM Powertrain' started by redneckarmyMP, Mar 19, 2011.

  1. redneckarmyMP

    redneckarmyMP Epic Member 5+ Years 500 Posts

    A friend of mine back home is having trouble with her truck.its an 02 Avalanche with push button 4wd. Im still deployed so Im tryin to help her from here so she wont be lied to at a shop or anything.

    The truck is stuck in 4hi. she has tried to get it into 2wd and 4lo but nothing... She said she can hear somthing under the truck (Im assuming the transfer case) attempting to disengage the 4wd but it never actually does it..so Ive ruled out the possibility of bad switches..any other ideas?


    thanks
  2. redneckarmyMP

    redneckarmyMP Epic Member 5+ Years 500 Posts

    anybody????????????
  3. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    Tell her to check the relays or fuse under the hood. Or it could be something bigger under the truck..
  4. adampaul1964

    adampaul1964 Epic Member 5+ Years ROTM Winner 1000 Posts

    Does she have the "Service 4WD" message? Most likely the encoder/motor. Push button 4x4 uses a motor to shift the transfer case in place of a shift lever. It also has a position sensor to tell it where it is, 2hi, 4hi or 4lo, Sometimes it's just the sensor, which can be replaced by itself or it's the motor itself. If it's the motor I believe it comes with the sensor as a whole assembly. She's probably going to have the codes read to determine if it's the motor or just the sensor. I just replaced mine a couple of months ago, mine was just the sensor but I had them replace the whole thing.
  5. redneckarmyMP

    redneckarmyMP Epic Member 5+ Years 500 Posts

    as far as i know shes not getting the famous "Service 4wd" message.but I'll ask her.thanks for the help guys.I'll bring these up to her and see if we can get this thing figured out.It'd be alot easier if i could see it myself haha

    Adam, that sounds like the most likely problem to me..from the way shes describing it to me, it seems like the motor is attempting to shift out of 4hi but just cant pull it off..would you happen to know what the technical term for the motor is?
  6. adampaul1964

    adampaul1964 Epic Member 5+ Years ROTM Winner 1000 Posts

    I'm pretty sure G.M. refers to it as the transfer case encoder motor.
  7. dsfloyd

    dsfloyd Epic Member 5+ Years ROTM Winner Gold Member 1000 Posts

    thats what they called it when they replaced mine. my problem was a little different from what was described, but similar in the 4wd acting up and no service light.
  8. redneckarmyMP

    redneckarmyMP Epic Member 5+ Years 500 Posts

    alright thanks guys. shes gonna go ahead and send it to the shop. but like i said i just didnt want anybody trying to take advantage of her and want to replace everything in the world to charge her some outrageous amount
  9. dsfloyd

    dsfloyd Epic Member 5+ Years ROTM Winner Gold Member 1000 Posts

    I hear you on that one.

Share This Page