1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

2002 Silverado with 5.3 running a little warm in traffic.

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by donyms, Sep 14, 2012.

Newest Gallery Photos

  1. donyms

    donyms Rockstar 4 Years ROTM Winner 1000 Posts

    I have a 2002 Silverado LS with the 5,3 automatic. I have recently had the coolant system flushed by the dealer and new Dexcool put in it also replaced the thermostat with the OEM 186 degree. My fan clutch was also not working right so I replaced that. All this helped but it is still heating up more than I like in traffic. If it is 90 to 100 degrees outside it can easily creep up to 220 to 230 in traffic and that makes me a little nervous. As soon as I take off driving the temp goes back down pretty quickly and stays between 190 and 195 when driving. This is not a crippling problem at this time but I know it should stay cool I.E. 190ish even in traffic because I had a 2000 Silverado LS with the same motor and transmission and it stayed the same temp all the time, about 190. My guess is that I have partial blockage in the radiator. My local radiator shop told me he has never replaced one of these radiators due to blockage and that my radiator was probably fine. Also i did check all the outlets on the radiator to make sure there was no blockage there and they are all good. Any ideas will be appreciated. :glasses:
     
  2. SurrealOne

    SurrealOne Former Member ROTM Winner 1000 Posts

    If you've got a blockage you might be able to verify it by feeling around for cool spots and/or uneven temperature on the radiator core (when the engine and coolant are at normal operating temperature, of course).
     
  3. bazar01

    bazar01 Member 2 Years 100 Posts

    To me it looks like a radiator blockage or worn water pump impeller since you already replaced the fan clutch.
     
  4. dpeter

    dpeter Rockstar 4 Years 500 Posts

    There was another gentleman who had a similar problem and his issue was the fan shroud had not been put back and rendered the fan fairly useless. Is your fan shroud in place and correct?
     
  5. donyms

    donyms Rockstar 4 Years ROTM Winner 1000 Posts

    Yes the fan shroud is in right and in perfect condition. Remember the dealer checked it out when they flushed the cooling system and they said it was either the radiator or the water pump but my guy that does nothing but cooling system work said he has never found a worn impeller on one of these trucks. I really want to think that it is partial blockage in the radiator but I want to be as sure as I can be due to it being an expensive part. :glasses:
     
  6. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    A check I've used over the years to test for partially blocked radiators is to turn the heater on full, if its a partially blocked radiator you should see a change in the temp, if it's a pump going bad the temp should stay about the same.

    I havent tried to get a radiator rebuilt for a few years but I'm guessing with the plastic radiators they dont Rod them out, pressure blast, resoldier, and pressure check any more.
     
  7. donyms

    donyms Rockstar 4 Years ROTM Winner 1000 Posts

    I put a new radiator in yesterday and that fixed it. It is running much cooler now, even on hot days and in traffic only warms up to about 199-201 and then cools down to 190 in about a city block after taking off. Thanks for all the help and suggestions I really appreciate it. I may put an electric fan in later, I think it would do even better in traffic then but I'm not sure how it would do going down the road at 75 or so. I am going to do some more research on this and go from there. I will also have to do an alternator upgrade for the efans so if any of you have done this already I would love to hear from you. :glasses:
     

Share This Page