1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

2003 Suburban doesn't shift into overdrive when its cold

Discussion in 'GM Powertrain' started by kennyb79, Jan 12, 2011.

Random Gallery Photos

  1. kennyb79

    kennyb79 New Member 100 Posts

    I've got an 03 suburban Z71 with 164,000 miles on it. I live in upstate NY, so when it gets cold out....usually from october to april...the tranny doesn't want to shift into overdrive. it usually takes about 10 miles or so before its warmed up enough so it will shift. is this normal that it should take so long. it shifts into overdrive just fine the rest of the year..and it always shifts fine into the other gears no matter what the outside air temp
  2. kennyb79

    kennyb79 New Member 100 Posts

    I bought the truck in febuary a couple of years ago (I bought it just south of rome down by the thruway) and I don't remember it doing it that first winter, but I know it did it last winter so I had the tranny flushed, but it didn't help. It works fine all summer long, but when the temp starts dropping it starts acting up. It just takes a long time to shift, maybe as much as 5 miles...shiftys into every gear fine, just not overdrive when cold. Kind of seems to me that its weather/pressure related somehow.

    gas mileage is a couple MPG worse on this suburban compared to my 99 i had before this, i blame that on the Z71 package.

    I've got a penn warranty on it, and I wouildn't mind getting the tranny fixed under warranty if I had to.
  3. sgtsjj

    sgtsjj New Member 1000 Posts 100 Posts

    my 99 does something along the lines of what your burban is doing, except mine does shift it just takes longer for it to until ive driven for a little bit and everything is all warmed up
  4. wildmans92

    wildmans92 New Member

    kenny i have a 2000, with 162000 on original trans i live in iowa mines does something similar. Being an ex-gm tech it is normal, it probably is in fourth gear what your seeing is the tourque converter not locking, and that deals with the trans not up to temp on cold days at below zero temps it can take 3 to 4 miles at 70 to hit full locked overdrive this is normal to warm up engine and trans faster any questions just ask.
  5. kennyb79

    kennyb79 New Member 100 Posts

    thanks for the input. I wanted to make sure that it wasn't something I should be taking care of. the fluid looks and smells fine, even tho it was probably a year ago that I had it flushed. I really don't abuse it until it warms up and shifts out of 4th, not generally anything over 55 mph, but I am a vol. firefighter, so there are times when I push it a little harder.

Share This Page