1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

2005 chevy avalanche service 4wd problem

Discussion in 'GM Powertrain' started by stereoclinic06, Apr 30, 2013.

  1. stereoclinic06

    stereoclinic06 New Member

    I use this site a lot to identify problems with my avalanche and I'm very greatfull to all the help I've recieved. I've been trying to figure out this service 4wd problem for a while now and I've finally got it. I have not seen this solution posted anywhere so I have to put it up. Most people were telling me to replace the 4wd selector switch, but I didn't want to do that without knowing if it would fix my problem. I took it apart instead and found loose solder connections on the plug pins the connect to the board. If you have a soldering iron this was a very simple fix. thanks again for all the information.
  2. Pikey

    Pikey Moderator Staff Member 1000 Posts 100 Posts

    Glad to hear that you fixed your issue.

    MOVED TO GM POWERTRAIN TECH***
  3. Enkeiavalanche

    Enkeiavalanche Moderator 1000 Posts 100 Posts

    Got pics of the easy fix??

Share This Page