GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

2005 silverado service 4wd message

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by Jordan661, Oct 10, 2012.

  1. Jordan661

    Jordan661 New Member

    Joined:
    Oct 10, 2012
    Messages:
    1
    Likes Received:
    0
    Hi guys, I have a 2005 z71 and until now (172,000 miles) it's been a great truck besides a transmission rebuild at 100k and now the service 4wd message is on and won't go off, and none of my buttons on the left side are lit up. It started just doing it every now and then And now it's constantly on. I tried all the tricks I used on my two previous z71's (an 03' and a 99') but its not working, tried starting and restarting, disconnecting battery, all of the above, do y'all think it could be a bad connection or an actuator, if so how do I find out? My scanner is only picking up 02 sensor codes which is the least of my worries lol any input would be greatly appreciated bc without 4wd in my line of work I'm screwed
    #1
  2. trentkoger

    trentkoger New Member

    Joined:
    Nov 23, 2012
    Messages:
    19
    Likes Received:
    0
    Look into changing your transfer case motor you will need to know your vin code and its pretty simple its three bolts and a wiring clip, had the same problem on my 2004 silverado.
    #2
  3. j cat

    j cat Active Member

    Joined:
    Sep 28, 2010
    Messages:
    1,522
    Likes Received:
    3
    what you need to do is have the GM drive train codes pulled with the scanner having this ability . then post what the code are.

    it can be many things causing this. check fuses. It is not uncommon to have the small wires to the transfercase break. the feedback sensor in the encoder is also a problem. could also be the transfercase is stuck.

    codes will reveal the area of failure. you may have to go to the dealership of the local tranmissiom shop.
    #3
  4. 84thProblem

    84thProblem New Member

    Joined:
    Nov 27, 2012
    Messages:
    5
    Likes Received:
    0
    I had this same message come up last weekend. I had backed up a steep, slick, grassy slope to load up while helping my son move out of his apartment. After spinning the rear wheels a little I switched to 4WD for a few feet. After loading up, I switched back to 2WD and noticed the message. I acknowledged it and it disappeared, hasn't come back - even though I had to duplicate the procedure again later that day.
    #4
  5. paracutin

    paracutin New Member

    Joined:
    Nov 1, 2011
    Messages:
    130
    Likes Received:
    2
    I agree with j cat. If you search the forum you will notice that the encoder is the culprit a lot of the time.

    #5
  6. j cat

    j cat Active Member

    Joined:
    Sep 28, 2010
    Messages:
    1,522
    Likes Received:
    3
    the encoder has feedback circuits that report the encoder position. if not correct you get a message. best check the fluid color make sure it is blue. if dark/grayish replace now to avoid any more damage.

    when switching into 4wd or out give the vehicle some time to complete operations before heavy loading up of the drivetrain.
    #6
  7. Pikey

    Pikey Moderator

    Joined:
    Nov 11, 2011
    Messages:
    4,232
    Likes Received:
    12
    I would start by crawling under the truck and unplugging and reconnecting connectors on and around the transfercase. The same thing happened in my 03. I played with the connectors and the light went off and never returned. I do agree with everyone else though the encoder motor on them are a known issue. But, you might gert lucky and have a corroded connection
    #7
  8. Kady

    Kady New Member

    Joined:
    Mar 15, 2009
    Messages:
    422
    Likes Received:
    3
    Sometimes the cause is as simple as the switch on the dash... I have the same problem, but never looked into it because until 2 weeks ago, it would only turn on randomly, and if I shut the truck off, and then back on, I was able to shift into / out of 4wd... But now I can only get it into Auto 4wd once in a while... So I gotta fix mine now too... Let me know what you come up with.
    #8
  9. j cat

    j cat Active Member

    Joined:
    Sep 28, 2010
    Messages:
    1,522
    Likes Received:
    3
    those encoder signal wires are very small and break easy. I know of one case where an owner was too hard on the wire harness on the driverside fuse box when changing spark plugs . he broke a wire . that wire was the encoder brake wire.
    #9

Share This Page