GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

2005 tb no heat

Discussion in 'Chevy Trailblazer Forum (GMC Envoy)' started by jaktomas1, Sep 6, 2012.

  1. jaktomas1

    jaktomas1 New Member

    Joined:
    Sep 6, 2012
    Messages:
    1
    Likes Received:
    0
    2005 TB dual climate control A/C works great, but only cold air comes out no matter what temp is selected.
    #1
  2. Pikey

    Pikey Moderator

    Joined:
    Nov 11, 2011
    Messages:
    4,232
    Likes Received:
    12
    You could try recalibrating the blend door actuator: I found this discription,
    For manual systems it does not matter where the a/c controls are set but if you feel the need to do something, turn the blower switch on (I prefer speed 3) and set the temperature sliders about .5" to .75" from full cold.

    For auto systems, press the auto button, with the key on.

    Turn the ignition off.


    Remove the HVAC/ECAS , 10 amp fuse in the underhood fuse box* or disconnect the battery for one minute.

    Install the HVAC fuse or reconnect the battery.


    Start the engine. On systems with auto a/c controls the controls will default to 74 degrees F when the ignition is turned back on.
    DO NOT TOUCH the a/c controls.

    Let the engine run for 1-4 minutes.


    Turn the ignition off for at least 10 seconds but no more than 30 seconds.


    Restart the engine and then test the a/c controls.

    Hope this helps
    #2
  3. RayVoy

    RayVoy Active Member

    Joined:
    Apr 18, 2012
    Messages:
    2,122
    Likes Received:
    5
    Pikey is right, it might be blend door actuators; my '05 Envoy XL (prev truck) had the same problem one year. It was only low coolant level and, it did not look low. It took very little to bring the level back to the full mark, but the heat worked great after it was topped off.
    #3

Share This Page