2009 Chevy Silverado 1500 Stabilitrak Problems

Discussion in 'Chevy Truck Talk & GM News' started by bad2009chevy, Jan 4, 2014.

  1. bad2009chevy

    bad2009chevy New Member

    Hi everyone.
    My 2009 Chevy Silverado 1500 has been giving me problems. It only has 80,000 miles on it but all the dummy lights for stabilitrak come on and it goes into reduced power mode(very scary). The dealer has replaced the throttle body sensor 3 times and it still gives me the same problem. Any suggestions?
     
  2. JMATT

    JMATT New Member

    Same thing happenned this morning.

    Happenned at 6:45 this morning. Im waiting to hear from the auto shop now as to what they diagnose as the problem. I'll keep you posted.
     
  3. silverad01

    silverad01 New Member

    how about the check engine light? it that on?
     
  4. Rob .Stephenson

    Rob .Stephenson New Member

    Here is my contribution to the same story :2011 chev silverado v6 40,000KM.[original owner] problem started just as warranty expired Stab./engine power loss/ etc. lights came on from extreme cold starts only,[-22C,-10F] not like others while the truck was in motion .Very rough idle.Took it to dealer where I was told it was a maintenance issue that the throttle body should be flushed out every 35,000 KM and it was clogged up with debris .Paid 400.00 for the computer test and service work[pissed off]. Worked fine for a while then happened a month later. Returned to dealer where the same code came up ,the whole throttle body was replaced with no charge to me.Why did I have to pay 400 bucks to flush something that they knew was faulty to begin with ? Im told to replace the throttle body at the Chev dealer would be about 650.00 Can.
     

Share This Page

Newest Gallery Photos