1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

2009 silverado electrical problem

Discussion in 'General Chevy & GM Tech Questions' started by 99 Z71, Feb 3, 2010.

  1. 99 Z71

    99 Z71 Member

    When I went to start my truck the other day the abs light came on, then while I was driving all of the gauges except for the volt gauge stopped working, even the trans temp, miles, etc read ---. After re starting the truck a few times everything worked fine. Later on that day after I washed it would not start it seemed like the fuel pump was not running then finally after about 5 minutes it started. I pulled 2 codes from it a P0230....Fuel Pump Primary Circuit; the other one was Lost communication with fuel pump control modual. I took it to the dealer and they could not find a problem. So later on I went to start it and it would not start it just keep cranking and then finally started about 10 minutes later. So now it is back at the dealer, I also heard there is a TSB on an electrical problem, any ideas.

    Last edited: Feb 3, 2010
  2. Jimmiee

    Jimmiee Epic Member 5+ Years 1000 Posts

    Good thing it's under warranty. Could be some high resistance in any number of connectors. Let us know what they find.
  3. 99 Z71

    99 Z71 Member

    Well the guy at the dealer told me all of the sensors and control moduals checked out ok, and they checked every electrical connection on the truck which i doubt due to the number and locations of them. they also said thecheck engine light is stil on
  4. RAMwoodworks

    RAMwoodworks New Member

    Could be as simple as a bad ground wire. Let us know what the result is.
  5. 99 Z71

    99 Z71 Member

    The guy at the dealer claims they checked "all" of the ground wires even though he probably doesn’t know where they all are.
  6. Jimmiee

    Jimmiee Epic Member 5+ Years 1000 Posts

    Well it's still under warranty. I hope they gave you a loaner car. :)
  7. 99 Z71

    99 Z71 Member

    No they didn’t even give me a loaner car. yesterday when they had it the service tech told me that he would like to keep it over night so I asked if I could have a loaner car and he said he would see what he could do and call me back, a half hour later he calls me back and says they couldn’t find anything wrong and I could pick my truck up. well later on I started to have the same problems so I took it back and parked it on an angle in front of their garage door so they couldent miss it, so they called me this morning and said they would take a look at again, they close soon and i still havent heard anything back.
  8. 99 Z71

    99 Z71 Member

    well the dealer called me and said they have a list of codes from my truck it seems like the computer lost communication with every control modual. they said they dont know whats wrong and will need to keep it over night.
  9. 99 Z71

    99 Z71 Member

    Day 3 at the dealer and they still dont know whats wrong
  10. Loggerhead Mike

    Loggerhead Mike Rockstar 100 Posts

    you need to go to a new chevy dealer

    sounds like you have a short somewheres causing the bus system to shut down

Share This Page