1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

2010 Stabilitrac and traction control

Discussion in 'GM Powertrain' started by donnie1, Feb 23, 2013.

  1. donnie1

    donnie1 New Member

    My 2010 Silverado LTZ is shutting off with the control center showing service stabilitrak and traction control with the engine light on. This has happened 3 times with the truck staring back up in a few min. Taking tit to the dealer on monday but want to know exactly what I am dealing with. I only have 52,000 miles and dont feel that I should have to pay for anything being that since I have had it, it's only been seviced with them. Please give some feed back on possible problems.
  2. Sierraowner5.3

    Sierraowner5.3 Active Member 1000 Posts

    well, unless you have been tinkering under the hood, it should all be under warrenty. sounds to me like some sort of electrical issue, but i could be wrong.

    Alex
  3. RayVoy

    RayVoy Active Member 1000 Posts

    Without the error codes that are setting the CEL, it is difficult to offer a possible.
  4. Your concerns are certainly understandable regarding the traction control and Stabilitrak lighting coming on. Please keep us updated on the dealership and overall repair process. If you send a PM, include your VIN#, name, contact information, situation, dealership, and current mileage. I hope this is resolved quickly for you.

    Matt,

    GM Customer Service (Assisting Evan)
  5. Burden33

    Burden33 New Member

    i had the same problem and it was my throttle body postioning sensor it sounds like you got the same problem
  6. ahmitchell1

    ahmitchell1 New Member ROTM Winner 1000 Posts

    Gm just released a recall for this I got a letter in the mail for it. It's water getting in your IP to body harness in the driver side door sill and causing different reading at your throttle position sensors to read different. Just let it dry out. Nothing had to be replaced on my truck and its fixed I just dodge the big puddles. If you drive through big puddles that'll do it. Or you might have a leaks check your windows
  7. nickgiacalone

    nickgiacalone New Member

    Not driving thru big puddles does not sounds like a suitable fix if I were in his shoes. You should not have to avoid large puddles while driving. We all pay our good, hard earned money for these trucks and should not have to avoid things like that. Personally, I love driving thru large puddles. Just my .02

Share This Page