1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

4-Way Electric 4x4 Selector has no indication and doesn't engage into other modes

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by REV_THS, Jul 12, 2013.

  1. REV_THS

    REV_THS New Member

    [TABLE="class: tborder, width: 1059"]
    [TR]
    [TD="class: trow2 post_content, bgcolor: #EFEFEF"]Hello fellow Bowtie members!

    I'm new to this forum and am seeking some insight about an issue i've just experienced on my 2006 Silverado 1500 EXT z71. I'll do my best to include as much detail about this issue and paint as best a visual picture to go along.

    So, I recently had my truck lifted (not sure that it plays a factor) but I just noticed that on the 4-way 4x4 Electric Selector on the left side of the dash next to the Odometer/Speedo, that I have no indication as to which drive my truck is in (Auto 4x4, 2wd, 4HI, or 4LO). I have searched Hi and Low under over and in the engine bay for any possible disconnected wire/plug, cracked case or leaking seals/bolts (and yes i know bolts them selves don't leak!!!). I have found None. I have verified that all Fuses are in good condition incase that might have been the problem (no luck).

    I've also tried testing numerous configurations of trying to see if its just the switch its self went bad but can't accurately tell. This test consisted of having the truck placed into Neutral gear while parked and pressing each drive selection button to hear/feel if it engages into another drive (auto, 2wd, 4hi, 4lo) and no luck.

    So, I not only have ZERO indication of what drive i'm currently in, but also there is no communication or command and response from the selector to the (and forgive my lack of proper terminology, but i'm assuming its called the transfer case?) to actually engage in the 4 possible options of drive.

    i hope someone here can provide some insight as to what might be the issue and hopefully it isn't an expensive fix as i know how touchy in price GM is and especially when it comes to 4x4 parts/repairs!

    Thanks again and look forward to the replies!

    [/TD]
    [/TR]
    [TR]
    [TD="class: trow1 post_buttons, bgcolor: #F5F5F5"][/TD]
    [/TR]
    [/TABLE]
  2. j cat

    j cat Active Member 1000 Posts

    check the fuses. on my 2000 the fuse is the ATC , auto transfer case . on some years this fuse is called something else. like TREC.

    if these fuses continue to blow it is the wiring or the encoder motor with short circuit.
  3. REV_THS

    REV_THS New Member


    Yes, i've checked the fuses... they haven't blown! i'm wondering if its just the selector switch or the encoder motor
  4. dsfloyd

    dsfloyd New Member ROTM Winner 1000 Posts

    if the switch doesn't seem to light up or work at all I would start with the switch then go to the encoder motor.
  5. Pikey

    Pikey Moderator Staff Member ROTM Winner 1000 Posts

    i would check the plug at the encoder motor. They may have not reconnected it after installing the lift kit. I had the same issue with my 2003 and it turned out to be a loose connection.
  6. j cat

    j cat Active Member 1000 Posts

    the 4wd switch light is not working [lighting up] this is supplied by the 4wd controller module which produces the 8 VOLT DC supply voltage . the fuses I mentioned apply power to this module as well as the encoder motor. the small gauge wires at the encoder carry this 8 volts. this is part of the feed back signal that tells the computer what position the encoder motor in the transfer case is in.

    it is very possible that these very fragile wires were damaged when they worked your vehicle. these wires are like the diameter of a hair.

    the control mode is behind the select switch . check for 12 volts and the 8 volts there , at switch see if you have the 8 volts.
    Last edited: Jul 13, 2013
  7. REV_THS

    REV_THS New Member

    So, funny story... the day I ran into this issue naturally my 1st instinct was check the wires for loose and proper connection (check all secure), then follow up with making sure power is making its rounds via Fuses etc... (check didn't find any blown fuses)... well last night I got frustrated and pulled EVERY single fuses in both the Cab and Engine Bay, as luck would have it some how I managed to miss 2 fuses, I replaced those fuses and Voila all is well in the world of 4x4 indication and drive selection! Sorry for all the brain busting and inquiring.

    Thank you also for those whom provided insight and feverishly advised checking fuses!
  8. j cat

    j cat Active Member 1000 Posts

    just so that others may gain from your confusion tell us what fuses were blown.

    also fuses blow for a reason ................
  9. REV_THS

    REV_THS New Member

    In the Engine Bay Fuse box it was the 30A Fuse labeled TREC and the Fuse Box under the dash (not sure this was related to it) but labeled TRC2 i think! I'd have to go back out and verify!

    the TREC is for sure related to the 4WD Actuator (some call it an encoder motor), but my assumption is that when my lift kit was being installed that the installers probably had unplugged the sensor from the actuator in order to gain access with out snagging or damaging the harness and replugged it back in without having taken power away via disconnecting the battery and might have gotten an over surge and popped the fuse.

    The other possibility is that when i was having a new Head unit installed that the audio store also may have done the same thing (excluding messing with the harness) but somehow caused an over load of power and popped the fuse.

    again this is all speculation, but things to look for if someone else runs into this dilemma.
  10. j cat

    j cat Active Member 1000 Posts

    that sounds reasonable to assume with what work was done ,that the fuse may have blown.

    time will tell. good luck and thanks for the feedback with your issues and corrected fix.

Share This Page