1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

4L60-E Trans Problem

Discussion in 'GM Powertrain' started by MikeO, Sep 25, 2009.

Random Gallery Photos

  1. MikeO

    MikeO New Member

    I have a 2000 GMC S15 and the trans appears to be in limp mode (only have reverse, 2nd, & 3rd) and the Service Engine Soon light is on. I found some great info on this site, and expected either solenoid a (1-2 shift) to be bad or a whole bunch of trans codes caused by bad power. I just got a scan tool and have the following codes.

    P0305, cylinder 5 misfire
    P0758, shift solenoid b electrical
    P0758, shift solenoid b electrical, pendingl

    It seems that solenoid b (2-3 shift) must be working because I have both 2nd and 3rd. That seems to imply bad power from the ignition switch and/or wiring from what I've read. I put a DVM on the trans fuse and measured 12.3V with ignition on and ~9.9V while cranking. That seems ok to me, but then again I'm not a mechanic. What do I check next? Thanks.

    Mike
  2. Jimmiee

    Jimmiee New Member 1000 Posts 100 Posts

    It's not uncommon to have a bad shift solenoid. How does it shift with the selector in D? Does it just stay in 3rd gear?
  3. MikeO

    MikeO New Member

    When in D it stays in 3rd. Starts in 3rd, stays in 3rd, won't go into overdrive.
    When in 3 it stays in 3rd. Starts in 3rd, stays in 3rd.
    When in 2 it stays in 2rd. Starts in 2rd, stays in 2rd.
    When in 1 it stays in 2rd. Starts in 2rd, stays in 2rd.
    2-3 only works manually and it shifts hard.

    Thanks again for your help.

    Mike
  4. MikeO

    MikeO New Member

    I replaced the 2-3 SS and the trans is working correctly. :happy: The bad 2-3 SS measured 3.5 ohm across the coil.
    Mike

Share This Page