4L60 issues

Discussion in 'GM Powertrain' started by GMCZ71, Apr 11, 2012.

  1. GMCZ71

    GMCZ71 Rockstar

    my 4L60 on my '96 has 248k on it and when im hard in the throttle (like im passing somebody), it feels like its hesitating or hitching. i was hoping you guys would have input for me. anything would be helpful cause i dont really want it to blow on me...lol
     
  2. GMCZ71

    GMCZ71 Rockstar

    I also have something else goin on. Sometimes when I take a right hand corner it shifts in and out of gear...any ideas would be helpful
     
  3. Strino78

    Strino78 Member

    Yup. I think we both know what it is. I've replied to quite a few posts regarding similar trucks in the last few days for different users, with the same diagnosis for all of 'em. Its time for a rebuild/replacement. That's a lot of miles for a transmission and you're right at the end of the service life for that transmission. It's happened to a few of us, myself included. It happens at about 150,000 miles/240,000 kms. Anything beyond that is simply a short term financial blessing.. because it will happen very very soon. Its a classic 4L60E failure and people describe them as late/sloppy shifts. To test it: put it in D not (D) and drive slowly up to 50-60mph and count your shifts. If you feel/hear only 1 shift, its time for a rebuild.

    Feel free to verify with other internet sources too.. http://www.wwdsltd.com/4L60/4L60ERepairs.html


    not too expensive to beef it up - just make sure you get a beast sunshell and corvette servos -- our trucks really needed these from the factory.
     
    Last edited: Apr 21, 2012

Share This Page

Newest Gallery Photos