Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

4L60E 1-2 shift issues...any advice appreciated

Discussion in 'GM Powertrain' started by rotaryenginepete, Jun 7, 2010.

  1. rotaryenginepete

    rotaryenginepete Rockstar ROTM Winner 100 Posts

    K so here's my problem: (by the way transmissions are my least favorite area to work on)

    My 07 Sierra started doing this roughly 3 months after I put on the 3" lift kit and 33" tires (i have taken it thru some serious mud and offroad terrain, and the trans was submerged a few times). During acceleration it won't shift out of first gear until 25mph at partial throttle or until I let off the gas at WOT. Also when I am on the highway and stomp on it, it will go from 3 or 4th gears down through 2nd right into first, so passing is a pain in the butt.

    I've partially diagnosed the problem so far. According to a manual I read it is either the 1-2 shift accumulator (possibly broken spring or seal) or the vehicle speed sensor. This weekend I am going to drop the pan, R2 the spring and seals on the 1-2 accumulator, maybe put an oregon corvette servo on also, and flush the thing out.

    The only other symptoms has been my parking brake and ABS lights will come on simultaneously every couple of days while i am driving down the road. but after a restart that goes away.

    My current mods that could affect the transmission are 3" suspension lift, 33" nitto trail grapplers, and bully dog GT tuner/programmer.

    any help from the transmission wizards out there would be helpful! thanks guys!
     
  2. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    4l60e 1-2 shift issues... any advice appreciatred

    Did you reprogram you trucks computer when you installed your 33" tires? If not your trucks transmission hasnt been shifting properly.
     
  3. rotaryenginepete

    rotaryenginepete Rockstar ROTM Winner 100 Posts

    yeah i reprogramed it for the tires. in fact that was the first thing i thought caused the problem was how i had the transmission set to firm shift and the speedo set for those tires, but i put it back to stock and the shift problem didnt go away. i also talkedwith bully dog and we walked thru some troubleshooting together but i can tell now its not the programmer, i think its something mechanical or directly inputting to the transmission
     
  4. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    4l60e 1-2 shift issues... any advice appreciatred

    I think Jimmee is the tranny wizard on this site but havent seen him latley. You out there Jimmee?
     
  5. rotaryenginepete

    rotaryenginepete Rockstar ROTM Winner 100 Posts

    thanks i messaged him. maybe hell be on here soon. anyone else thats good with trannys, let me know if you have ideas! THANKS
     
  6. Jimmiee

    Jimmiee Epic Member 5+ Years 1000 Posts

    The easy way to diagnose this problem Pete is to hook up a good scanner and go for a ride. Kick down the transmission and watch the scanner. See if the computer commands an upshift. If it does and the transmission doesn't upshift then you have a valvebody problem. Sticking valves are common problems on these transmissions.

    On the other hand if you kick it down and it stays down in the lower gear when it should upshift then the computer is not sending the signal for some reason. The reason may be a faulty speed sensor, TPS or possibly a Mass Airflow problem. OR the problem may be the aftermarket programming.


    If it were my truck and I eliminated the valvebody as the problem I would then remove the reprogramming and see if the problem goes away.


    Finally you never mentioned if you have any hard codes, history codes, pending codes or any freeze frame data?
     
  7. rotaryenginepete

    rotaryenginepete Rockstar ROTM Winner 100 Posts

    i havent been able to bring up any codes, but i will make a run to orielly's and see if they can scan it. the bully dog will bring up general codes but i don't think specific ones. i have tried reprogramming back to stock..it didnt change the problem so that led me to believe it was mechanical. i will def try your idea though, to see what the computer is actually telling the truck to do vs. what it is doing, thanks for your help! i'll keep you guys updated as i work it
     
  8. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    4l60e 1-2 shift issues... any advice appreciatred

    Most auto stores dont have high tech scanners. You may want to find a shop with a good scanner such as a SnapOn or equal and pay to have them scan your truck while you drive it. Depending where you live, most shops charge between $45.00 to $75.00 to scan your truck. This most likely will be money well spent.
     
  9. rotaryenginepete

    rotaryenginepete Rockstar ROTM Winner 100 Posts

    Jimmiee, I was wondering this listing http://www.gmtruckhq.com/?q=node/93 is out of a transmission manual. my problem best fits # 2 and 3. so this is why i think it may be mecahnical because programming it back to stock settings didn't fix the problem. but it does say TPS as the first thing to change..maybe i got water/mud all up in mine offroading lol
     
  10. rotaryenginepete

    rotaryenginepete Rockstar ROTM Winner 100 Posts

    ok i'm looking at replacing the TPS now...but i still plan to drop the pan and do the accumulator and corvette servo work.
     

Share This Page