4WD not engaging

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by generalduke01, Mar 22, 2009.

  1. generalduke01

    generalduke01 New Member

    I have a 2000 Chevy Silverado 1500 4x4 with an 5.3 liter motor and auto transmission. Over the past few months the truck has failed to go into 4 low at times and the service 4 wheel drive light comes on once in a while. I changed the transmission and transercase fluid but the light continues to come on sometimes. Now it will not engage in either 4 low or 4 hi. I have a push button selection on my dash to engage the 4 wheel drive and neither the 4 hi or 4 low will light up or engage. If anyone has any ideas of what could be going wrong, please let me know. Thanks!
  2. 04sierracrewcab

    04sierracrewcab New Member

    i have heard of the "button module" going bad..
  3. Springthing

    Springthing New Member

    Yep. Seems to be a common enough problem - either the module with the switches (go to a scrap yard to get a replacement to see if that helps solve the problem for now while you order a new one) or; the actual actuator for the 4WD. There is a way to check if it's the actuator on the transfer case but I can't recall how it's done. Doing a quick search on the forums should bring up the post.

    Does anyone know how to check the actuator and do you feel like typing it out?

    Thanks!
  4. Appliancepresident

    Appliancepresident New Member

    Have you checked the 25amp fuse for the 4wd?
    I have a 97 and the 4wd not working but mine blows the fuse and it means the acuator is shorted, you can chk for 12 volts to the acuator have someone under it while press the 4hi or low button but I would first chk the fuse box.
  5. mjalstad

    mjalstad New Member

    I don't know if this is the best way or not, but when it went out on my Suburban I removed the actuator and watched it while somebody put it it 4WD. It didn't move so I bought a new one and my 4WD worked great after that.
  6. spazzoid13

    spazzoid13 New Member

    i had the same thing happen to my 04, since i had recently baught it, i took it to the dealer still under extended arranty, and it ended up being some sensor was all jacked up..when the light came on, it wouldnt do anything, turn truck off, back on, it would engage just fine, no light, then after a while it would come back on..rinse, repeat.

    went to dealer, they swapped out the sensor of sorts, and all is well now.
    i wanna say they(dealer) woulda charged something to the tune of 200 for sensor, and install, but i could be wrong, was several months ago
  7. John W

    John W New Member

    I had that happen to me just ater I bought my 2000 Z71. No shift to 4wd. The actuator on the front diff was burned out and had shorted and burned the electronic shift unit on the transfer case. The truck was second hand but the dealer covered the cost of the transfer case unit ($800 ) they said, and I paid half the cost of the diff actuator ($90). At least those are the prices I got from the GM dealer.
  8. Ron505

    Ron505 New Member

    My 2000 Z71 switch on my dash went bad. Very inexpensive fix for how aggrevating it was at times.
  9. Madman

    Madman New Member

    this might be a dumb repsonse but
    are you sure your putting it in nuetral before you are engaging 4 lo?
    also my truck i need to wiggle the steering wheel a little
    its kinda finniky
  10. desrochesj

    desrochesj New Member

    The chevy's have had lots of trouble with the actuator on the transfer case so that's where i'd be looking first!
  11. corova

    corova New Member

    1994 blazer had simular problem it was the acuator pulled part off junker and worked perffict
  12. bluenblack

    bluenblack New Member

    99 silverado service 4 wd drive light came on. And, I reacted the same you did-- changed the trasmission and transfer case fluid. The light would not stay on all the time though. Did not know at the time that it would not go into 4wd. Did not learn this until I was at the outerbanks. Took the acutator off-- it is on the front gear box. Had a buddy hold on to it and pushed the buttons it did nothing so I thought the actuator was bad (this would have been bad at the outerbanks). I stood out side the truck and was playing with the buttons and the acutator worked. There was an apparent short in something inside the swith (even though solid state). You might try pushing the swith 'hard' side to side. I did this and still had a great vacation. Changed the switch out in the parking lot of the GM dealer. The panel prys off -no tools required-, a screw driver to take two screws out, pulls the connector out the back. Never has had a problem since. This is really a cheap thing to try before you go tearing into anything in the four wheel drive components. And these switches are a known problem.
  13. Comdrop9073

    Comdrop9073 New Member

    Try shifting the transmission to neutral and shift it into 4 lo/hi, you can also try rolling the truck forward or reverse slowly and hitting the button while it is rolling. If it doesn't engage ask a friend to hit the button while you are under the truck, listen for the motor, if you don't hear it you can remove it from the transfer case, hit the button and see if it will move. Like others have said before it is probably the problem.

    Will it shift to neutral?
    Last edited: May 12, 2009
  14. Mean_Green_95

    Mean_Green_95 New Member

    My brother's '04 Z71 did the something similar to that. He got rear-ended and his 4WD started acting stupid. I borrowed his truck a while back and notice it was in 4 wheel auto, so I put it in 2WD. I was driving down a major highway doing 55-60, just minding my own business when WAM! the transfer case went into neutral. He brought it to the only shop in the Parish, other than the dealer, that would do 4WD work. The said it was the sensor on the transfer case. Then they said it was the actuator on the transfer case. They then said that in order to take the actuator out the transfer case had to be in neutral. They couldn't get it to go in neutral. They then found something wrong with the wiring. Supposedly he is getting his truck back by friday. So needless to say, the Z71's have some problems. If you can get a manual 4WD selector, DO IT!
  15. peanstein

    peanstein New Member

    MIne was the same and it was cold solder joints

    The 2 WD lights on my 99 Z71 would turn on and off as i would tap the dash at different places. It would not engage in 4Hi nor Low.
    I hoped it was a bad contact so I took the switch apart and was trying to pry the pcb off (printed circuit board) and realized that it would not pry off unless I removed the solder from the top side of the connector. I decided not to remove them but simply resoldered all the solder points on the board and also cleaned the little gold contacts inside the black rubber piece. they are the ones that make the contact on the gold piece on the pcb. I also cleaned the contact points where they contact the board.
    Put it toghether and my 4x4 switches on and off like it is suppose to.
    I would suggest anyone having intermittent light issues etc. It doesnt cost u anything except for a few minutes taking it off/apart and finding a soldering iron.

    Good Luck!



  16. steverocks6

    steverocks6 New Member

    well since i work at a junk yard i can tell you the switches are a main cause and a high sought for item, also you cant just jump and take out actuator and see if it will engage due to fact if its the switch thats bad then the actuator wont engage... also pushing the truck wont change anything, when you select 4hi (witch you can do while moving doesnt have to be in netural) the light will flash untill it is engaged, also if your switch lights don't even blink when you first select your 4wd then replace the switch, if they light up or blink but still wont engage look into the actuator
  17. titen201

    titen201 New Member

    I’m no expert byany means; I can just tell you what I did to get my FWD running again. I have a2000 Chevy Silverado, Extended Cab, and Long Bed with 180,000 miles. I boughtthe truck about one an a half years ago or so, and the FWD didn’t work backthen. So, last summer I started working on it. I did just as you have done, andlooked it up on the internet. I went to a number of different sights hopping Icould find a quick fix and save a lot of money. After reading I found things Icould do with the help of youtube videos. I did the following:
    1. Lookedfor a blown fuse. I only found one fuse that said FWD, and it was the one onthe inside of the cab. Looked good. So that wasn’t it.
    2. Changed the selector switch. You know the pushbutton thing, in the cab. This wasn’t it either.
    3. Changed the actuator. Nope not it.
    By this time I wasnot too happy; therefore, I did the unthinkable, I took it to the Chevy Dealer.After all having a FWD truck, but the FWD doesn’t work, just don’t seem right.Kinda got my feelings hurt when they said “$100.00 dollars an hour.” No thanks.So, I did without the FWD last winter. Luckily, it wasn’t a bad winter.
    So, before thiswinter, I was bound and determined to get it working come hell or high waterthe things gona work. After replacing all the parts last year and it stilldidn’t work, I knew it had to be electrical.
    I found a web site that has all the electrical informationfor my truck or any vehicle for that matter. It’s called alldata.com. Granted,I did have to pay like $25.00 for a year, but I did it anyway. And, low an behold,there is a fuse. It’s not labeled FWD, its labeled ATC. (Automatic TransferCase) It’s under the hood with all theother fuses. So, I don’t know what the actual problem was or how the fuse gotblown, all I know is after doing all the steps above and replacing this fuse,it’s working. I just had to try them all, I guess. Good Luck!!! And thanks everyone that posted on here. ITWORKED. I don’t know which one done it, and don’t care. I got my FWD back.
  18. dashaint

    dashaint New Member

    I have the same issue, my push button switch appears to work, it flashes then can hear it engage and the light switches to 4HI but still no 4wd is engaged... can tell by stepping on the gas and rear wheels spin and feel no tug on the front wheels at all. I removed the ATC fuse and the 4wd fuse for 10 minutes and that had no effect at all. I'm going to pull the actuator out and see if it moves when i hit the buttons... if not, i guess i'll change the switch. trying to avoid paying $70 for a switch which i know they won't allow me to return as it's electronic... any other tests i can do?
  19. j cat

    j cat Active Member

    so you have 4wd hi but not 4wd lo ? all the button lights normal and no service 4wd error message ?
  20. dashaint

    dashaint New Member

    it will switch from 4 hi to 4 low back to 2hi and auto 4wd no problem... of course in neutral for 4 lo, last night when i was driving it in 4 hi... just to see how it would do... after a few minutes the service 4wd light came on and it would not shift out of 4hi.. wouldnt shift to anything else. this morning when i started it up, i immediately hit the 2 hi button and it went back to 2 hi and if i did the same thing over again i'm sure it'll get stuck again.

    - - - Updated - - -

    i did recently replace the transfer case... my other one was toast in 4 low... strangely i was having the same problems with the other transfer case and another front end as well. i went to 4:10 hd front end, and rear, didnt like it, went back to my 3:73 diffs. so maybe it is my switch...?

    - - - Updated - - -

    Front diff actuator is working fine... extends in 4 hi/lo and retracts in 2hi. Still... when i get on gas only back wheels pulling, no tug on front diff... can turn sharp and no resistance like when it used to work in 4wd. it really will spin the back tires... get all sideways and everything. i checked the propellor and vehicle speed sensors... all is connected, no lights are coming on.. what the hell?

    - - - Updated - - -

    yesterday i checked all the wiring to all the sensors on the transfer case.. all is good. today am going to try another actuator from my 4:10 front diff and going to check the voltage going to the connector. anyone know what it should read when i hit the button?

Share This Page