1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

4WD Problems

Discussion in 'GM Powertrain' started by ejj, Aug 26, 2009.

Newest Gallery Photos

  1. ejj

    ejj New Member

    Hi -

    I have a 2005 Tahoe Z71 with just over 80k miles. This morning, when I fired it up, the 4WD selector indicated that the system was in neutral, and wouldn't allow me to select anything, 2H, 4H, 4L, Auto, it didn't matter. Each selection caused the button's light to blink for a few seconds, and then the neutral light re-lit.

    At the same time, the check engine light came on.

    This afternoon, when I left the office, the 4WD selector worked perfectly normal. I could select, and engage, any setting. Still had the CEL though.

    About a month ago I got a "Service 4WD" message and the system though it was in 4L, even though it clearly wasn't. Again, about a day later, everything went back to normal, and I was able to select and engage any setting.

    Any advice on the place to start to diagnose and solve this problem?

    Thanks!
     
  2. tattooed4life

    tattooed4life Epic Member 5+ Years 500 Posts

    I would check to see if you have any codes stored and then go from there.
     
  3. ejj

    ejj New Member

    OBDII codes, TCM codes, ?? I'm not sure which modules on the truck have retrievable codes at this point...
     
  4. tattooed4life

    tattooed4life Epic Member 5+ Years 500 Posts

    obdII codes is where I would start, especially if the 4x4 service light had been on.
     
  5. ejj

    ejj New Member

    I have a P0447 - EVAP DTC code, nothing transmission/4wd related.

    4WD system has still been fine other than the one drive...
     

Share This Page