1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

4X4 issues after engine/trans rebuild

Discussion in 'General Chevy & GM Tech Questions' started by 96_Tahoe, Jun 8, 2010.

  1. 96_Tahoe

    96_Tahoe New Member

    I had to pull and rebuild my engine and trans a bit ago, and ever since it was all put back together I have had this issue. I am assuming we missed a connection somewhere, just hoping somone can point me in the direction.

    It is a 96 Tahoe

    When I activate my push button 4x4, I hear the T-case engage, but the light on the dash blinks non-stop and I get nothing from the front wheels. If I am correct the front axle has a solenoid that is air powered to lock it in, is this my issue?
  2. MrShorty

    MrShorty Epic Member Staff Member 5+ Years 1000 Posts

    Yes, there is a CAD (Center Axle Disconnect) on the front differential. I wouldn't call it air powered, but I don't know if '96 still used the old thermoelectric style CAD or if they had started using the newer all electric CAD (my '98 uses the latter). Checking to make sure the CAD is plugged in and working sounds like a good place to start.

Share This Page