1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

4x4 not engaging

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by Slick8675309, Aug 14, 2014.

  1. Slick8675309

    Slick8675309 New Member

    Hi folks, 2000 GMC sierra push button 4X4. My issue: when I first got the truck I knew the 4X4 did not work. The indicater lights are/were not on & "Service 4WD" lit up on message board. I never got around to fool with it until today. So here's what I got: the fuse (15A) in the dash panel, not blown, fuse (ATC) (20A) in the under hood panel blown. I think great ! simple fix. I replaced the fuse started the truck and all indicater lights came on in the push buttons and service 4WD message is gone, then 2WD (or whatever it's labeled) stayed lit. Put truck in neutral pushed 4HI indicator light blinks and I can hear a clicking behind the buttons, then it switches back to 2WD indicator, same with 4LO. Tried this again 4HI blinks and then all indicator lights are out and service 4WD message is back. Checked both fuses neither were blown, put them back in and indicater is lit again and message is gone. Tried 4WD again with same results, pulled fuse under hood put it back in and everything is "reset" So ? I'm open to thoughts, suggestions ? Please keep in mind this is my time working on 4WD system and I know nothing about them and not very vehicle savy :money:
  2. BurbanMan

    BurbanMan Member 1 Year 500 Posts

    Pull the push button selector and make sure your getting power through it. I would think a test light should be sufficient to do this.

    Will 4wd engage If you put the truck in "N" and select 4hi or any other selection?
  3. Slick8675309

    Slick8675309 New Member

    It does have power going to it because it lights up after I pull the fuse and put it back in. and no it does not go in 4X4 at all.
  4. BurbanMan

    BurbanMan Member 1 Year 500 Posts

    Ok. Did you make sure your getting power from it?
  5. Slick8675309

    Slick8675309 New Member

    No that I did not do, I'd check for that on the 4X4 motor at the transfer case ?
  6. BurbanMan

    BurbanMan Member 1 Year 500 Posts

    at the button. Power going to the button has to get out of the button

Share This Page