1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

4x4 problems

Discussion in 'GM Powertrain' started by JamesE, Dec 7, 2012.

  1. JamesE

    JamesE New Member

    My 4wd is not engaging, and making a disturbing sound. Before i tear into it, i would like to discuss. I have trolled the forums and have not seen my exact issue. Sorry if this is obvious but im not coming up with it.

    My truck stopped going into 4High. Push the button, flash flash flash and nothing. no sound from module or actuator. Push 4low, a nice solid chunk and we are in business. Solid light on 4 low. Push 4low again, the lights would change to indicate solid 4high, blinking 4low, but stay in 4low. Push 4high, truck would return to 2wd.

    To start simple repairs, i disconnected the battery for an hour.

    Now things get interesting. When i push 4high or 4low, there is a LOUD clank, and no engagement at all. Tried a few times. The module clicks and the Transfer Case case goes CLANK really loud and nothing. I drove the truck and tried again, and the CLANK got louder, almost violent. you can feel it through the whole truck. Even my kid was like "What the hell was THAT!?". so i stopped pushing buttons.

    I figure i can replace the Switch, Module and Actuator, but before i start this project, I would enjoy some feedback.

    Thanks all, and Happy Holidays
    James
    Oakland
    First Time Poster
    Last edited by a moderator: Dec 9, 2012
  2. RayVoy

    RayVoy Well-Known Member 2 Years 1000 Posts

    Welcome to the site James, I don't think it is any of the above. I have no experience with the t-case (been lucky), but I feel I am knowledgeable about the theory of operation.

    I think you have a bad encoder motor.

    From what I have read, very easy to change. If it was me, I would do a search on encoder motor to ensure my guess is correct and, to ensure you feel comfortable changing it.

    Regardless of the eventual outcome, occasionally changing the t-case fluid is a good idea.
  3. BillM

    BillM Rockstar 100 Posts

    Welcome to the Club, James.
    As Ray mentioned, you may be able to run a test on the encoder motor? Disconnect the motor from the transfer case, and open up the gears. They could be damaged. An aquaintance had a similar problem with his Avalanch, and there was some plastic gear damage and pieces jaming the encoder? My encoder does not have any plastic in it??
    A test may be possible by having the encoder motor hang by the electrical cable and running through the buttons - 4 Low; 4 High; 2 WD; and Auto if you have it. The encoder motor should move through the positions as the buttons change.
    I am sorry, but I did not get the make model and year.
  4. JamesE

    JamesE New Member

    Thanks Guys,
    I hit the pick and pull today (saw a 99 yukon new to the yard) and claimed the dash switch, under-dash encoder, front actuator, and the rear motorized transfer mechanizm (that would be the encoder motor, right?).
    Ill start by changing the transfer case oil, because i'm pretty sure i hear noises from each part of the system. Maybe those plastic gears are shredded inside the encoder motor, so i'll go there second. Not hard to remove, but requires a few tricks. Gets a little tight against the drive shaft. Thanks for the guidance.
    Happy New Year-!
    james

    - - - Updated - - -

    PS.
    1997 GMC Suburban SLT K1500
  5. JamesE

    JamesE New Member

    Hi All-
    okay, the pick and pull parts didn't match.
    So- replaced NEW Dash switch, NEW front Actuator, New Encoder Motor (Transfer case motor).
    Truck goes into 4lo again, but no 4hi.
    Getting the blues. any further advice?

    thanks
    james
    97 suburban K1500
  6. RayVoy

    RayVoy Well-Known Member 2 Years 1000 Posts

    James, the only thing left is the TCCM (Transfer Case Control Module), it's the brains of the whole system. It would be nice to get a loaner from a friend, with a matching truck, to try
  7. JamesE

    JamesE New Member

    Ok, swapped out the brain from under the drivers dash.
    Nutty! same exact symptoms. No 4hi. 4low is perfect, a total grunt monster.
    I am baffled.

Share This Page