5.7 suburban HELP i have reached a deadend

Discussion in 'GM Powertrain' started by cipman5916, Jun 17, 2009.

  1. cipman5916

    cipman5916 New Member

    Hey guys, I am a new member, though i have browsed through the site for a long time. Well guys here is my problem, yesterday as i was leaving my house i got a very rough 1st gear shift and then half a block later all of my dash warning lights came on, and my truck stalled. I tried to restart it but nothing, then i noticed that my pump was not working. That afternoon i got in the task to change my fuel pump and i did but still the pump does not work. I have also tried to turn the truck on my putting gas in the intake but it still does not start, it cranks right like if it were about to start but nothing. also none of my dash warning lights light up when i place the key in the start position. I am leaning towards my computer, but i dont want to buy a new one if i don't need to. I have also checked some of the wiring and the fuses, and now i have reached the point were i dont know what is wrong with my truck. :neutral:

    1996 gmc Suburban c1500
    5.7 Vortec 225k all stock.
     
  2. grimreapersshadow

    grimreapersshadow Rockstar 100 Posts

    check your relay under the hood it might have burnt up also check your ground at the tank make shure its bare metal touching bare metal or it wont ground properly
     
  3. MrShorty

    MrShorty Epic Member Staff Member 5+ Years 1000 Posts

    Start with a few basics: IS the pump getting power? If not, where is the problem in the fuel pump circuit? If the relay isn't closing, is the PCM telling the relay to close? If the PCM isn't telling the relay to close, does the PCM have power? Don't forget to check grounds. If the PCM will talk to you, are there any codes in the PCM?

    See where that gets you.
     
  4. cipman5916

    cipman5916 New Member

    I checked the ground that connects to the fuel pump, i dont really know how to check the pcm or the relay. Though what i find weird is that even if i put gas in the intake to get the truck running i get nothing. I am leaning towards the ignition switch, though it does crank and all of the windows and power works, just no power to the pump or the plugs, and none of my lights in my dash come on when i turn the key. What do you guys think? Could the switch be my problem? How could i test it? Thanks a lot guys :great:
     
  5. daddytech

    daddytech Epic Member 5+ Years 500 Posts

    If none of your dash lights are coming on i would start with the easy stuff, sounds like there is no power what so ever to anything, Start with the battery and make sure the terminals are good and clean and that there is a good connection. Check that it is fully charged or that there is power to it. if not then more than likely it's the alternator that has died on you. the hard shift thing should not have much at all to do with what is wrong with the truck (at least I wouldn't think it does,doesn't make sense)

    the way you can test your relay for the fuel pump is to bridge across the plug (would not suggest you try that for the PCM though might do irreversable damage) worst case scenario your pcm might just be bad. some parts stores now have testers for those too. might take it off and see if it's still good or not. if all of your electrical stuff comes back on when you check the battery connections and the battery voltage I would move to the computer next.

    be sure to post your resolution on here as not only will this be an interesting one to see the source of the problem but also so that others can benefit from your experience
     
  6. cipman5916

    cipman5916 New Member

    Here again, i am about to tackle the switch but before i do, i want some more input. I guess i forgot to state on last post, but i do have power on my radio, windows and everything else, problem is that when i turn the key it cranks, but none of my accessory (Service Engine Soon, Batt,or airbag light) Lighst light up like they normally would. this is what leads me to believe that it may be my switch, and i also found a posting on another site where they had a similar problem on a s-10. Let me know what u guys think. :sign0011:

    here is the link:
    http://chevroletforum.com/forum/archive/index.php/t-12146.html
     
  7. bry2500

    bry2500 Epic Member 5+ Years 1000 Posts

    After reading that other post I would have to agree that it is your ignition swith. try doing the same test thta was done on there, bypassing the switch.

    Hope you get it fixed.
     
  8. cipman5916

    cipman5916 New Member

    ITS FIXED!!!!!!!!!!!!:party: Thank you guys for your input, the switch was the bad guy here, it was sending power everywhere else expect to the engine. When i was taking it out, it appeared that the previous owners had already repaired it, but they just cut the wires rather than put a new part in. The switch is pricey ($127) but i saved money by doing the repair myself, and it only took 1 hour. The mechanic wanted 400dls to fix it all:grrrrrr:. I will try to post some pictures and if you want some a better detailed process, let me know guys. :great:
     
  9. ahm1127

    ahm1127 Rockstar 100 Posts

    I guess you added additional switch on dash to start your truck, seen this on a few chevy's. Congrats.
     
  10. hmaster77

    hmaster77 Rockstar

    lol u should have put a push button switch for the ignition that would have pretty sweet
     

Share This Page

Newest Gallery Photos