1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

83 K10 Starting Issue

Discussion in 'General Chevy & GM Tech Questions' started by racefan88, Mar 15, 2011.

  1. racefan88

    racefan88 New Member

    My truck usually turns over all of the time but ocasionally it wont turn over. Just out of the blue it wont even click but the amp meter goes down. Left me stranded earlier today and have no idea what the issue is. It has a reman starter on it about a month ago. I also cleaned all grounds and electrical connections. doesnt seem to have any pattern on why it does it; just when it wants to i guess.

    Any help appreciated.
  2. stephan

    stephan New Member 1000 Posts 100 Posts

    If your ampmeter is going down then your ignition switch is functioning. You need to go over the basics again because you've missed something. Recheck your battery posts, cable clamps, batt - to engine ground, chassis ground etc. Don't just look at them. Take them off & clean them with some sandpaper till they're shiny. Double check your Battery + to solonoid connection since your starter was recently out. Maybe they left it a little loose & it's floating.
    **When it left you stranded, how did you get it started? Did you have someone jump it? Did you just keep trying it & it finally started? This would be usefull information to help you diagnose this problem.
    Last edited: Mar 15, 2011
  3. 2COR517

    2COR517 New Member 1000 Posts 100 Posts

    Sounds like a couple of dead spots on the starter. Is the ammeter (I'm guessing it's actually a voltmeter) dropping when you turn to the Start position?
  4. racefan88

    racefan88 New Member

    I started it by bump starting it. It is a 4 speed. The voltmeter does go down. I went to start it before i went to school and it did turn over. it seems like when i let it sit it turns over. I drove my extra car anyways but when i got home it would not, same problem.
  5. dualdj1

    dualdj1 New Member 100 Posts

    probly a bad starter. some when they go bad won't crank when hot

Share This Page