1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

"85" GMC Suburban , 350 5.7L // Hi speed acceleration loss. Is it carb problems?

Discussion in 'General Chevy & GM Tech Questions' started by Gonzo, Aug 19, 2014.

  1. Gonzo

    Gonzo New Member

    I own a 1985 , GMC Suburban , C1500, 350, 5.7L , and I took it on a long road trip this past weekend . Everything was fine, until I reached speeds of around 70mph . The truck started to hesitate as if it was it was not getting enough fuel, or as if it was misfiring . As I slowed down to around 55mph or so, it would some what clear out and stop what it was doing , and run better . As I accelerated , it would start doing it again .Ive hit a stump. I cant figure out what it is . Is it a Carb issue ? Maybe a fuel pump issue, not getting enough fuel at high speeds? Is it electrical? I just replaced all my spark plugs, wires, distributor cap, rotor, and coil. Im clue less now . I hope I can find some answers here.
    Thanks,
    Gonzo
  2. Stretch56

    Stretch56 Member

    Since you've ruled out the electrical side, my guess is the fuel filter.

Share This Page