1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

89 cargo stepvan 30 I killed the spark

Discussion in 'GM Electrical Tech' started by jimvg54, Nov 9, 2011.

Newest Gallery Photos

  1. jimvg54

    jimvg54 New Member

    the rig is setup to RV someday. had multi battery's tried to move it and put the battery from my van in it. the ignition wires are not connected to the post so I hooked them to the positive then I made the big OOPPs .. I CONNECTED THE NEG TO THE + AND THE PLUS TO THE - i THEN TURNED THE KEY AND THE DUAL BATTERY VOLT REG SMOKED. then i noticed the neg terminal had the ground wire on the lug and it was on the positive. the coil is short and has a iron bar around it and 2 plugs with two wires in the smaller gauge wire plug and one wire and a test terminal in the other. the distributor has two plugs / one comes from the coil (two smaller wires) the other plug from the harness . I don't understand what is going on with the coil and dist with all those wires. seems to be 12 volts to coil but after that I really don't know what to look for. I do know that I have no spark from the output of the dist cap. that was sure dumb now can anybody help me get that boat running again.

Share This Page