Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

89 TBI 454 won't idle

Discussion in 'General Chevy & GM Tech Questions' started by lucaslaw, Jun 20, 2009.

  1. lucaslaw

    lucaslaw New Member

    3500 truck, 207000 miles, supposed to have been rebuilt.

    I replaced plug wires, plugs, unhooked "brown wire" connector under glovebox and held throttle with a clamp (to keep it running) to adjust timing to "0", plugged brown wire back up, still won't idle.

    Cleaned IAC, checked vacuum hoses, there is a device about the size of a half pack cigarettes with a plug and wires on one end and a vac hose attached to intake on other,its loose under air cleaner, is this the MAP sensor? Could this be the problem? Cound the TBI need rebuild? Spray pattrern looks good.

    Now the check engine light is on, I don't have a OBD 1 scanner, is there a jumper/count flashes method to determine the code?

    Stumped
  2. Jimmiee

    Jimmiee Epic Member 5+ Years 1000 Posts

    You need to jump the ALDL at pins B and A.

    Attached Files:

  3. lucaslaw

    lucaslaw New Member

    No code, followed procedure to reset IAC. Got it to idle at 450rpm, shut it down, plugged IAC back in, now it won't idle and will barely start.

Share This Page