1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

91 S10 Blazer Lighting Issues Continues

Discussion in 'Chevy S10 Forum (GMC Sonoma)' started by jenkznza, Jan 12, 2014.

  1. jenkznza

    jenkznza New Member

    I've posted about this previously, but would like to continue here.

    The symptoms.

    When I turn my headlight on my right hand turn signals turn on front and back, but don't blink and the signal shows solid on the gauge cluster.

    If I turn my right hand turn signal on without the head lights on the hazards come on.

    The left hand indicator works just fine.

    What I've done:

    I change out the indicator/hazard switch in the column along with the rest of the wiring.

    I've looked for ground issues. Can't find any.

    I pulled fuses.

    When I pulled the T/L Ctsy fuse the signal light on the dash disappeared and the turn signal didn't come on with the head light. I didn't have any running lights either. Everything else remained the same.

    I pulled the stop/hazard fuse. The hazards still came on with the right hand indicator, but didn't work otherwise.



    I am at a loss. Any ideas?

Share This Page