95 GMC K2500 Sub no start/fuel injector

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by csanfordjr, Apr 15, 2017.

  1. csanfordjr

    csanfordjr New Member

    Hello everyone,
    I have a 95 k2500 suburban I was having some issues that led to a mechanic telling me to replace my fuel injector myself. I was told how to replace it and ordered a new injector. After replacing the injector the truck acted like it wanted to start and I heard a loud clunk like something underneath broke. Now when trying to start it just makes 1 clunk. The truck only has 96K miles and starter was just replaced a month ago. I know the issue is from something I may have messed up on I'm just not sure where to look or if I am totally out of luck and ruined the engine. Any information or ideas i should try or look for would be appreciated thank you.
     
  2. P-Dub

    P-Dub Member

    which engine do you have?
     
  3. csanfordjr

    csanfordjr New Member

    Forgot to include, I have the 7.4 454.
     
  4. P-Dub

    P-Dub Member

    so you pulled the upper intake manifold to get at the fuel injectors. How far did you have to dig to get to the injectors?
     
  5. P-Dub

    P-Dub Member

    AC, did you disconnect that to get in there? There really isnt anything in that area short of the distributor that actually moves. Did you pull the dist?
     
  6. csanfordjr

    csanfordjr New Member

    I didn't have to remove much just the intake and then the 8 screws to get to them. I replaced the one on the left. I made sure i didn't pull anything else by mistake. I noticed it was leaking alot and it doesn't seem to want to lock back in I stopped messing with it once I realized I messed up.
     

    Attached Files:

  7. P-Dub

    P-Dub Member

    whoa, yours look totally different from mine. I have a 99 and I don't have any of that stuff in there. I figured it would be similar, but it aint.
    Someone will have some good info for you. I cant really help you. Sorry.
    good luck.
     
  8. Beachbourbon

    Beachbourbon Active Member 100 Posts

    I believe 92-95 are different from 96-99. BTW, does it actually start or just clunk w/o starting? Have you rechecked the starter?
     
  9. xPosTech

    xPosTech Epic Member 5+ Years 1000 Posts

    And check the battery. You might be hearing just the solenoid on the starter. Turn on the headlights and try to start. If the headlights go out or dim when starting recharge battery.

    Ted
     
  10. csanfordjr

    csanfordjr New Member

    It literally sounds like something is broken. I tried jump starting it. Instead of one clunk it makes really bad noises. I have a 5 sec video of how it
    sounds.

    It went from sounding like it was going to start to something just sounding like it exploded and now this.

     

Share This Page

Newest Gallery Photos