95 silverado no reverse

Discussion in 'GM Powertrain' started by Astu1986, Mar 17, 2012.

  1. Astu1986

    Astu1986 New Member

    i just bought a 95 silverado Z71 w 187,000 miles the truck will not reverse and has a hard time coming out of first gear, i have to take it over 3k or close to 4k rpms for it to shift, the heat will not blow but ac blows cold he said the truck overheats at times..i dropped the transmission pan to take a look the fluid was dark and shinny and also found metal shavings and shards-picture attached, im thinking im gonna have to drop the transmission but would like any input or thoughts on what i should do since moneys tight. thanks for ur time
     

    Attached Files:

  2. rileyjr16

    rileyjr16 Rockstar 3 Years 1000 Posts


    I'd suggest putting a test guage on the test ports and checking the pressures before you do anything. And change oil and filter, conventional wisdom says do not flush as it may cause total failure. Maybe change the solenoid valves and booster valve to get a little more time out of the transmission. My brother had problems with his 99 4L60E; changing the filter and valves and got almost 80,000 more miles out of it after a transmission shop told him it was shot. Do some research on the internet to find out what the right pressures should be in each gear. You can find a pressure gauge on ebay at a pretty reasonable price.
    By no means am I an expert but I have seen my dad do some amazing things :lol:
     
  3. Astu1986

    Astu1986 New Member

    thanks riley ive done some research on the trans and it seems like my sunshell might be gone, do u kno if the pressure test would tell me if the sunshell would be gone?
     
  4. rileyjr16

    rileyjr16 Rockstar 3 Years 1000 Posts

    Do not know. I'm not a real big or intelligent transmission diagnostic guy. I sent the link to my dad and this thats what he sent back ^^. I'll give him a call when he gets off of work but that might be a while. Maybe [MENTION=48417]Coach24[/MENTION] [MENTION=50075]SurrealOne[/MENTION] [MENTION=48263]Red Z71 Max[/MENTION] [MENTION=25112]Scooter[/MENTION] [MENTION=25901]Jimmeh[/MENTION] [MENTION=53846]GM Tech[/MENTION] can enlighten more.
     
  5. SurrealOne

    SurrealOne Former Member ROTM Winner 1000 Posts

    Sadly I'm not a transmission guy so I'm of little use in this thread. Small, indescriminte shavings are pretty normal in an automatric transmission but some of those in the photo are HUGE. Between that and the fact that the tranny is slipping, I'd be headed to have it repaired since I'm not transmission-savvy enough to do it, myself. :(
     
  6. Jimmeh

    Jimmeh Epic Member 5+ Years 500 Posts

    Sounds and looks like you definitely have a broken sunshell. My suggestion is quit driving it and rebuild. good luck!
     
  7. rileyjr16

    rileyjr16 Rockstar 3 Years 1000 Posts

    Thought when the sunshell goes out you USUALLY lose more than just reverse.
     

Share This Page

Newest Gallery Photos