1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

96 s10 Fuel, Water Temp and Voltage Gauges dont work!

Discussion in 'Chevy S10 Forum (GMC Sonoma)' started by rx7srlife, Dec 13, 2009.

  1. rx7srlife

    rx7srlife New Member

    I just bought a 96 s10 and thought it had 3/4 of a tank of fuel until I ran out of gas after I only put 100 miles on it. It has a 2.2 and a 5-speed, I figured the fuel milage should have been better than that. and when i ran out the Fuel gauge still read 3/4 of a tank. I had also noticed that when I turn the key off none of the other gauges move or even reset to zero when I start the truck. The only gauges that work in the cluster are the speedo and the Oil Pressure. What could be the cause. I know the single 10 amp fuse in the side of the dash is still good. It wouldnt be the cluster's gound or else none of the gauges would work. I pulled the cluster out and tested it with a power probe and both the volt meter and fuel gauge needles move in opposite directions when you put power to the signal side and ground the ground terminal on either of the gauges. this is the first vehicle I have ever owned with a printed circuit board cluster. Please help. My only oither option is to start chasing wire and oh what a lovly time that is. I wasnt going to post but the only other topics I had found like this were for newer s10s with the newer cluster style.

Share This Page