1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

97 gmc k1500 4x4 issues :(

Discussion in 'General Chevy & GM Tech Questions' started by Rejekt xo, Apr 1, 2011.

  1. Rejekt xo

    Rejekt xo New Member

    Ok i searched for a while on the forums and on google etc, and i can find some of the things but not everything. Today i decided to take the truck for a ride down by a creek to see how it is for fishing this weekend, and it was rather muddy. being as i have my rear 2 tires good and front 2 balding i decided it would be the perfect time to try out the 4 wheel drive. I had only used it in the winter about half a dozen times only to pull out of my yard after a snow storm and it worked fine. Today i put the truck in park pushed the 4 hi button and it blinked and the 2 hi button stayed lit it blinked for 2 seconds ( the 4 hi light) and then turned off and stayed in 2wd. i tried the same for 4 lo and the same thing. i tried it in gear while rolling and everything and it still wouldnt work. and i found some info on this but what i didnt find out was that after i tried this i tried once i got back on the road and the lights wont even turn on anymore. only the 2wd light stays on and thats it. im rather confused, and not too familiar with push button 4wd as ive only ever ridden in manual 4x4 or full time 4x4. Any info would be greatly appreciated sorry if this question has been asked many times!

    truck details just incase there needed:
    1997 gmc sierra k1500
    4.3 v6 vortec engine
    automatic trans push button 4x4
  2. 2COR517

    2COR517 New Member 1000 Posts

    If it goes back to 2wd it's likely the encoding motor.


    If you search for actuator there should be dozens of threads that will illustrate how the system works and how to diagnose it.
  3. Rejekt xo

    Rejekt xo New Member

    thanks for the info. i decided to look underneath the truck and there was a plug under the transfercase that was unplugged, plugged it back in and the 4x4 started working. but only in 4 low, 4 high wont engage. im not having any problems with 4 low as i tried it out today but i cant seem to figure out why the 4 high isnt working now :/

Share This Page