1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

97' GMC Safari A/C problems.

Discussion in 'General Chevy & GM Tech Questions' started by ZSI52, Jul 31, 2009.

  1. ZSI52

    ZSI52 Epic Member 5+ Years 500 Posts

    I need some help with this one. My mom has a 1997 GMC Safari and the A/C messed up. It has 4 different fan speeds and only 2 speeds work. When you try to switch the fan speed the A/C just shuts off. Any ideas?
  2. bill190

    bill190 Rockstar 100 Posts

    If you have a "blower motor resistor", check that. And check the electrical connector at the fan and/or blower motor resistor.
  3. div4scpro

    div4scpro New Member

    I have 97 K1500, your problems sound similar. the control panel/module; the one with the AC on/off, recirc, and blower speed knob are very prone to failure. you can lose just the AC on/off function, the blower speed can can vary up and down, or you can lose the defrost function all at once or just one sympton at a time. there is no way to fix that controller once it starts to go. They cost approx 200. let me know what other symptons you are having.
  4. daddytech

    daddytech Epic Member 5+ Years 500 Posts

    My wife's suburban was doing the very same thing and it was the switches on hers too. I put a brand new blower motor in hers because the bearing in the old one had come out and it was squealing very loudly. put the new motor in it and it runs fine now but only on low and High , the middle speeds are all seemingly not working then the switch replacement and eureka works on all speeds once again.
  5. StaTTiKK

    StaTTiKK New Member

    hey daddy tech

    How are you man. Having a similar problem with a 96 tahoe. All the functions on the ac heater control work, ie defrost, floor vent etc, however, I have lost all speeds of airflow except for the maximum or highest setting. I was just wondering, where you might have found the control switch replacement? Did you order a new one or? I think my problem is in the high low switch only. Who knows.

Share This Page