1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

97 z71 4x4 light blinking ?

Discussion in 'General Chevy & GM Tech Questions' started by tndukguy, Nov 5, 2010.

  1. tndukguy

    tndukguy New Member

    Hey guys I got a 97 chevy z71 and the truck shifts in to 4hi and 4lo front tires not pulling and 4x4 button lights blink . I checked all fuses and all ok I pulled front acuator and had a friend put truck in to 4hi and nothing from the acuator but what is this acuator ment to do ? I am no ase mechanic but I have some skills thanks to us army.. . I mean it didnt click or move so I priced one at auto zone 80.00 need to make sure this is the prob first thanx guys..
  2. 2COR517

    2COR517 New Member 1000 Posts

    If you have voltage to the actuator, but it is not extending, it needs to be replaced.

    Check for voltage with the key on, transfer case in 4wd.

    The actuator forces a splined sleeve to move, which engages the pass side axle to the diff carrier.

    And, thank you for serving
  3. tndukguy

    tndukguy New Member

    So when I do this the acuator should go in and out when 4x4 is engaged and dis engaged the way it looks to me is telescope type deal that should extend out and then retract in when 4x4 is pushed to 4hi and 2hi ? thanx
  4. vncj96

    vncj96 New Member 1000 Posts

    If the actual switch is bad it will do the same thing, I would also test the switch for the 4x4 selection.

Share This Page