1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

98 Jimmy 4x4 switch

Discussion in 'GM Powertrain' started by otis24, Nov 1, 2009.

  1. otis24

    otis24 Member

    O.K., the 4x4 was not kicking in on my 98 Jimmy. A mechanic at the GM dealership where I work stated that it was probably the encoder motor. I just swapped the encoder motor with one from a salvage yard. It seemed to work fine at first, but now it is still doing the same thing:

    4x4 Hi will not respond/engage from 2Hi (either from park or neutral). When you push the 4 Hi button, nothing happens, or it flashes and kicks back to 2 Hi. If you put the vehicle in neutral, allow the vehicle to roll and push 4 Lo, the 4x4 lights blink and the 4x4 kicks in, but bothe the 4 Hi and 4 lo buttons stay illuminated. Are they supposed to both stay illuminated?

    According to the owners manual, if they do this then the 4x4 switch needs to be adjusted. How do I know if I have another bad encoder motor or a bad 4x4 switch? Can the 4x4 switch be adjusted? What else might the problem be? Any help would be greatly appreciated.

Share This Page