1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

98 Suburban 4wd question?

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by My98Suburban, Dec 18, 2011.

  1. My98Suburban

    My98Suburban Member

    Just bought a 98 Suburban K1500 i have a question about the 4wd..The switch doesnt see to light in any postion,2wd,auto or 4hi or 4lo but seems to work,then sometimes the light does go on in 2wd drive only?...What causes this?...is there any way to fix this?....Thanks...
     
  2. NagRuTan

    NagRuTan Rockstar

    Greets,

    Press hard around the switch site and see if they light up. A few of us have had loose contacts on the back side of the plugin.

    Nag.
     
  3. My98Suburban

    My98Suburban Member


    Thanks how does that switch come out so i can check that and clean the connections up?....
     
  4. NagRuTan

    NagRuTan Rockstar


    Greets,

    I pulled the dash to get to it. Not to hard (at least on my 99).

    Nag.
     
  5. My98Suburban

    My98Suburban Member

    Ok i will try pressing on the switch 1st then what else could it be if it doesnt go on? lite up?
     
  6. janikphoto

    janikphoto Rockstar 3 Years 100 Posts

    My switch works fine, but it has a hole in it. I think the previous owner always pushed on it too hard and broke through the lit up part of the switch, where the plastic is thinnest. I plan to find a new one and just swap it out. You should consider doing the same if it's not a loose connection. At least the 4WD works. A switch is a cheaper fix than a solenoid or a transfer case!
     

Share This Page