1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

98 Tahoe ignition in "run" doesn't power fuses

Discussion in 'GM Powertrain' started by Rascl93, May 14, 2012.

Newest Gallery Photos

  1. Rascl93

    Rascl93 New Member

    98 Tahoe 5.7 4x4

    When the key is in the "run" position or the "accessory" position several fuses don't get power - hence things don't work. No power windows, no wipers, no radio, no fuel pump relay - pretty much everything that you would need to be in one of those two positions to work. Truck starts and runs good once oil pressure is up enough to bypass the fuel pump relay.

    At least my many issues seem to have come down to one common issue.

    Any suggestions - I've read about contacts in the ignition corroding? What can I do about that. We have replace the ignition cylinder, but that's it as far as steering column components.

    Thanks. :)
  2. dipstick

    dipstick Member 2 Years 100 Posts

  3. Rascl93

    Rascl93 New Member

    Thanks - that helps a bunch. I believe this is my next project to see if that solves the problem. :)

Share This Page