Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

98 Z71 battery drain problems

Discussion in 'GM Electrical Tech' started by Aftershock77, May 1, 2012.

  1. osgprometheus

    osgprometheus Member 2 Years 100 Posts

    Ahh, I missed that. My bad
     
  2. Aftershock77

    Aftershock77 New Member

    Well, I just got done pulling every fuse and And relay (using a test light to test). Nothing shut it off. Its still getting draw from something. The only thing I can think is a relay stuck on that I cant get to. I heard theres a lighting relay that has caused a lot of problems for 98's. Anyone else hear about this?
     
  3. Dana W

    Dana W Member 2 Years 100 Posts

    Yeah, mine did that. Broken hinge on the mirror covers, both of them. The cover could not hold the plunger switch down. It took two of us a couple of days to find the problem. You can't see the mirror lights with the cover closed unless you are staring right down the slit between the cover and mirror frame. What's worse, the bulbs DO NOT come out of their sockets. I had to remove the bulb & switch harness from both visors.
     
  4. Strino78

    Strino78 Member

    My truck did this very thing, and it was the starter.

    It was very intermittent over the course of a year until it happened constantly. I did a thorough check/cleaning of the entire electrical system attempting to isolate the problem. I had a known good alternator, a strong battery, good grounds, alternator wiring -- and I had this dead battery syndrom. My truck would start every time with a boost and with a fresh battery, but after being driven and then left for a while before restarting it would be "dead" and need a boost. My lights, radio, horn all worked -- but then would go dead when keyed to start with no "click" from the starter.

    The starter didn't have any play to it, and spun freely with 12V directly to it -- it would just kill batteries/need a boost after I got the truck started and drove around for a bit and then let it sit for a while.... While I was re-installing the starter... it was a deja vu moment.. I had this happen at the track with the T/A.... heat soaked starter.... Replaced the starter and I haven't had the problem occur ever since! :)

    Those poor old starters get a lot of abuse for only being engaged briefly... it runs for maybe 1-3 seconds, but has to endure tens of thousands of miles stuffed under an exhaust manifold baking.. at rest.... heh....


    I'm saying this based on the info you've given: 14V at the battery..which you wouldn't see if the alt. was bad.. and not indicating that you have a Batt/Charge light on the dash being lit up.. you just now need a boost to get started for some reason after running around.... Do your lights/radio work before boosting?

    That's how mine started to go... lights and radio worked, but no solenoid click with the key turned...



    Hope this helps.
     
    Last edited: May 28, 2012

Share This Page