GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

`99 Express 3500 Security light on and won't start

Discussion in 'Chevy Express Forum (GMC Savana)' started by Bugzturbo, May 7, 2012.

  1. Bugzturbo

    Bugzturbo New Member

    Joined:
    May 7, 2012
    Messages:
    3
    Likes Received:
    0
    I have a 1999 Express 3500 cargo van that I have owned for about 2 years now. The other day I went to start it and the battery was dead (been about a week since I used it). Put my jumper on it and it cranked and fired, but dies immediately. Tried again, same thing. Then I realized the security light was on. This has never happened before since I owned it. I changed the ECU about a year and a half ago and did have to reset the security then, but it went fine and have never had the issue again. Problem is, now I cannot get it to reset no matter what I do I've tried "key on for 10 minutes", "key on for 30 minutes", "key on for 10 minutes then off for 5 seconds, 3 times" and also "crank then leave key on for 10 minutes then off for 5 seconds, 3 times". Nothing is working. The light never goes out at all except when I turn the key off. What am I missing here? Also tried the "lock/unlock drivers door" trick too, but it is a cargo van with no power options, so I really didn't expect that to work anyway. Been messing with this damn thing for 2 days now to no avail. Any help is appreciated. Thanks

    Bug
    #1
  2. Bugzturbo

    Bugzturbo New Member

    Joined:
    May 7, 2012
    Messages:
    3
    Likes Received:
    0
    Anyone? Anyone??....... Bueller?
    #2
  3. moogvo

    moogvo Moderator

    Joined:
    Mar 11, 2006
    Messages:
    1,281
    Likes Received:
    7
    I don't want you to feel like nobody is reading, but I don't have a good answer for you other than to contact the dealer and see what they say. I had this happen on a Pontiac Aztek once and it had to go to the dealer on the hook to be fixed.
    #3
  4. Bugzturbo

    Bugzturbo New Member

    Joined:
    May 7, 2012
    Messages:
    3
    Likes Received:
    0
    Yeah, I called the dealer hoping they might give me a tip on what to do, but they wouldn't tell me anything but "bring it in". They want $150 just to look at it. Not fix it, just look at it. They can kick rocks.
    #4
  5. rjgoss

    rjgoss New Member

    Joined:
    Feb 17, 2013
    Messages:
    3
    Likes Received:
    0
    I have a 99 chevy sub and it started something like that bout three years ago. For the last two and half years I stick the key in and turn just until the lights on the dash come on, make sure security light is not blinking and it starts right up everytime for the last two and half years. No dealer no nothin!
    #5
  6. BowtieExpressNC

    BowtieExpressNC New Member

    Joined:
    Jul 1, 2013
    Messages:
    6
    Likes Received:
    0
    I just bought my 99 express 1500 5.0 a few weeks ago.It just did it the second time yesterday. would start & stall immediately I noticed the security light flashing.the 1 st time I kept trying different things it eventually started.Yesterday it didn't start it was flashing I was in a hurry maybe 4 or 5 minutes so I left it when I returned a couple hours later it started right up.MY question is how long does it normally take to quit flashing? Also do you turn on the key & wait or keep turning on/off till it stops flashing?I really appreciate any help thanks
    #6
  7. rjgoss

    rjgoss New Member

    Joined:
    Feb 17, 2013
    Messages:
    3
    Likes Received:
    0
    No no, just turn the ignition on without starting the car and stop. When the dash lights all come on check to see if the security light is on. If it is not blinking, crank it up. Mines start everytime like that. If the security light is blinking don't try to start it, it gonna have to sit for ten minutes.
    #7
  8. BowtieExpressNC

    BowtieExpressNC New Member

    Joined:
    Jul 1, 2013
    Messages:
    6
    Likes Received:
    0
    I'm having this problem it had been only every couple of weeks now it did it twice in 2 days & right now it wont start I waited 10 min.s & it quit flashing I turned key it immediately started flashing again.the second time I pulled the neg for 10-15 mins waiting now but it was flashing again when I reconnected the neg terminal?? any insight would be appreciated

    - - - Updated - - -

    Now it started little afraid to trust it again but Its restarting every time I try it so far
    #8
  9. rjgoss

    rjgoss New Member

    Joined:
    Feb 17, 2013
    Messages:
    3
    Likes Received:
    0
    I'm sorry, i didn't clarify. U have to do the pause EVERYTIME you start the car. Once it doesn't start on you, you have to wait. Pause at ON position for 3 to 5 seconds then start from there. It's been working for me for about two and half years.

    - - - Updated - - -

    I'm sorry, i didn't clarify. U have to do the pause EVERYTIME you start the car. Once it doesn't start on you, you have to wait. Pause at ON position for 3 to 5 seconds then start from there. It's been working for me for about two and half years.
    #9
  10. BowtieExpressNC

    BowtieExpressNC New Member

    Joined:
    Jul 1, 2013
    Messages:
    6
    Likes Received:
    0
    thanks I m sure that wil help.I do remember turning it more quickly that time.Do you know why the pause everytime? Is there a thread you know of that explains the pausing? Its not a bing deal I just like to understand it better?Also has anyone had this issue resolved dealer or otherwise?? thanks again you really helped me so much!!
    #10
  11. BowtieExpressNC

    BowtieExpressNC New Member

    Joined:
    Jul 1, 2013
    Messages:
    6
    Likes Received:
    0
    I think I ve finally got this problem beat! of course the proof is in the pudding .I let you all know if it holds out to be fixed. I ve been so frustrated w/ this security light flashing intermittantly. This is my service van I go to peoples homes to make repairs.the worst on was the lady who had 10 minutes to get to a funeral when I was parked facing downhill outside her garage door. Ive been searching for info re "security light flashing" to no avail.I decided to take advantage of one of my 10-12 min breaks to read the manual to see what instructions they gave. I wasn't aware the systems name Passlock So I started to search "How to permanently disable GM passlock system" on google thankfully I found several options out there.much of the info is to allow you to bypass it for installing remote start system.I chose the one that seemed easiest for me.unfortunatly I wasn't able to get pics.I couldn't find anything that told me exactly which wires on the express van.I pulled the clam shell trim around the stearing column on the ignition switch there are 2 sets of wires one has several larger wires.thats not what your looking for.This is a small plug w/about 3 small wires one of those small yellow with the van running(its very low voltage) I cut the yellow wire in a couple seconds the SECURITY light came on permanently.thats exactly what the instructions said would happen.I chose to install a toggle switch in the bottom panel to allow remaking the connection to allow the relearn procedure in case of a dead battery etc. just flip the switch back on to allow relearn security system. depending on the year made there are 3 different passlock systems this should work for 1,2.Ill let you know how it holds out

    - - - Updated - - -

    There is another option to ohm the resistor in the key & match it w/ a resistor in the ignition wires.this should eliminate the SECURITY light always on,
    Last edited: Sep 16, 2013
    #11
  12. BowtieExpressNC

    BowtieExpressNC New Member

    Joined:
    Jul 1, 2013
    Messages:
    6
    Likes Received:
    0
    One week and it is working as expected. before this it had been flashing at least a couple times a week. So far so good! :great:
    #12
  13. BowtieExpressNC

    BowtieExpressNC New Member

    Joined:
    Jul 1, 2013
    Messages:
    6
    Likes Received:
    0
    still no more issues with that problem:party::party:
    #13

Share This Page