1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

99 silverado.. gas and temp gauge went out

Discussion in 'GM Electrical Tech' started by slammedchevy, Aug 7, 2008.

  1. slammedchevy

    slammedchevy New Member

    bout a month ago i was hookin up an indash in my truck..and me bein as stupid as i am didnt have the key turned off..so some wires touched.. sparked..and now my gas guage, temp gauge, gear light indicator dont work..i think it might have something to do with the ignition. cuz with the key half way forward the gear light indicator comes on..but with the truck on they go off. please give me some advise..i've been guessin and guessin and cant find the problem..bought new guages..checked all the fuses..replaced an ignition relay..
  2. vncj96

    vncj96 Epic Member 5+ Years 1000 Posts

    first off, is this a 99 that had the newer body style or the old body style, because if its the old then you have to replace the whole instument cluster that i know for sure, but my brother has an 01 and i would think you still would have to replace the whole cluster, but you could have actually killed the wires, yes this is possible to fry the wires if it was a good enough shock
  3. slammedchevy

    slammedchevy New Member

    i relaced he cluster to see if that was the problem..still didn't work..i think fryin the wires is most likely the problem..it could be one ground or one power wire that fried cuz i know random things share the same wire..the high beam light indicator..gear light indicator..temp gauge and gas gauge..and the battery light..im almost positive that has to be the problem but now i have to hunt down wiring diagrams..or play a guessing game to find a short and possibly mess more stuff up.

    oh and its the new body style..the 99-06 pretty much have the same dash
  4. brandonjf1

    brandonjf1 New Member

    hey i dont know if you've fixed the problem or not but the same exact thing happened to me on my 2002 silverado. I havent been able to fix it. Need some help
  5. 99'HEARTBEAT

    99'HEARTBEAT Epic Member Staff Member 5+ Years ROTM Winner 1000 Posts Platinum Contributor

    Exactly.....which Gauges are not working at all or just part of the time in your Dash Cluster??.....the reason I ask, is that the problem is most likely with the stepper motor's for the gauges.....are going out/bad and need to be replaced,

    Here is a picture of the backside of the dash cluster.....and the stepper motor's are Circle in Red and those are
    what needs to be replaced with New ones,

    [​IMG]
    Last edited: Mar 21, 2011
  6. brandonjf1

    brandonjf1 New Member

    The Gas and Temp Gauges dont work at all. The PRND321 Display only comes on when the key is on the ACC setting, not at any other time. The Battery Light is Always on and the Highbeams indicator doesnt come on ever.
  7. Ponder

    Ponder New Member

    Anyone ever figure this out? My 99 silverado is having the exact problems as in te original post. Have replaced cluster and checked every fuse. Same problem. Please help

Share This Page