1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

99 silverado problems starting

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by 99silverado99, Jan 14, 2008.

  1. 99silverado99

    99silverado99 New Member

    ok I have a 99 chevy silverado
    -4.3 liter V6
    -AUTO tranny
    -140333 milage
    -was sitting for almost 2 years
    - had the part of the block where the starter bolts on welded and a new hole drilled and tapped, because it was broken off
    -just drove it from lousianna to colorado begenning of this month.
    -the oil and tranny fluid, fuel filterand oil filter were changed prior to the drive to colorado
    -spark plug wires are a year old but wern't driven on since i drove it to colorado
    -changed the spark plugs yesterday.
    -my ABS light, Brake light, and engine light are all on.

    Its been running pretty decent given the time it sat.
    its been starting up pretty bad since i got it running, but the last coulple of days its been really hard to start.
    this morning it took me holding the key for about 1 1/2 min, the first time nuthing happened, then i held it down for about another 1 1/2 min. and it finally started.

    any help would be appreciated.
  2. tbplus10

    tbplus10 Super Moderator Staff Member Platinum Contributor 1000 Posts

    Take it to some place like Auto Zone and get the codes read. It sounds like you have multiple problems.
  3. 99silverado99

    99silverado99 New Member

    well i just found out today that I can get the codes read at the auto craft shop on post "which is a on post garage where you can work on your vehical"
    and ya i kinda figured i had more than 1 problem I was trying to see if any of these has happened to someone before because it could be 1 of many differant things.

    also I forgot to put in there the engine light has been on since i had the truck over 3 years ago, when it ran like a kitten.

    also the gas gage hasnt worked since i had it.
    it will randomly bounce from full to empty and never tells the right thing.

    any ideas "I'm not to worried about that cuz its just a nuisence problem but still if its a inexspencive fix then i'll fix it."
  4. Tralr8d4x4

    Tralr8d4x4 New Member

    If it were me and I had access to a garage and some time, I would pull the throttle body off and clean it. Get yourself several cans of the cheapest carb cleaner you can find and spray the hell out of it. MAke it shine. Get all the ports, everything. Then, get some cans of brakleen (the stuff in red that's chlorinated - it works better, trust me) and spray everything down again. This will get the residue off. Let that evaporate and put it all back together. Fill the tank and put 2-3 bottles of fuel injector cleaner in it and run the hell out of it for a while. See if it will clear up. For the hard starting, it sounds like the idle air control valve is stuck or clogged. If you clean the TB that will clean that also. If your fuel gauge doesn't work that will trip a CEL also. Give that a try. Will cost you about $25 and a couple of hours to clean it all.

    HTH

    JB

Share This Page