Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

99 silverado with flashing check engine light

Discussion in 'General Chevy & GM Tech Questions' started by rotax583, Jul 16, 2010.

  1. rotax583

    rotax583 New Member

    hi! this is my first post on here.i bought a 99 silverado 2500 with a 6.0L.it had starter problems and I just got it fixed and tried it for the first time tonight.the truck starts well but idles a little low and rough.when I got it to about 70km the check engine light started flashing.when I got home and left it at idle the light stopped flashing.now the previous owner told me it would burn plug #1 when he would give it a good run(abuse it).what could be causing this? it also has dual exhaust...not sure if it came like that.
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    You will want to get the codes checked... Also when was the last time the truck had a tune up? After you get the codes pulled from the computer then you will have a way to troubleshoot and a better direction.
    Also welcome to the club
     
  3. rotax583

    rotax583 New Member

    the truck hasnt had a tune up in a long time.i forgot to mention it has 300000 kms on it.the oil pressure is very good and the truck pulls well.I got 8 new plugs for it and im going to change oil to.what should i use for oil with the mileage it has?I believe the guy told me he put dynomax exhaust on it.im wondering if the sensors may have something to do with this.anyways im going to get the dealer to check the codes then im going to give it a much needed tune-up
     
  4. grrr...

    grrr... Rockstar 100 Posts

    Flashing CEL indicates a misfire. If the light starts to flash, you need to pull over and shut off the engine. Allowing it to run during the misfire could cause a lean condition in the cylinder where the misfire is and result in engine failure. My suggestion would be to replace the spark plugs, wires, dizzy cap, and rotor button. After that, disconnect the battery both pos and neg, then touch the cables together and hold for 10-15 seconds. Holding the cables together resets the ECU fully. Then replace the battery cables on the battery, + then -. Finally, start the engine and allow it to idle with no load (ie. headlights off, radio off etc) for 10-15 mins for the ECU to relearn idle. After that time, take it out for a ride and check for the CEL. Hope that helps.
     
  5. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    On the 1999 Silverado they have coil on plug no Dist cap or rotor. Just to clarify. And a new set of wires would be a good idea as well.
     
  6. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    To add to what grrr said, if the light stays on its emission issue and o.k. to drive, but should be fixed.
     
  7. rotax583

    rotax583 New Member

    so I changed the plugs this morning.I had 1 plug that was covered in oil...it looked like grease and carbon.the rest were good.the check engine light is gone off.the only thing now is the gas gauge.I put 40$ of gas in it and the low fuel light was still on.I still find it run like its missing a bit.maybe I will have to change that same plug again untill the carbon gets out of it.new wires will be in on monday.
     
  8. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Sounds like you have a bad sending unit in your tank for the gas guage.. Another common problem in these trucks. And do a Seafoam treatment on the motor that will help clean the top end out...
     
  9. rotax583

    rotax583 New Member

    thanks for all the replys,I went for a good ride tonight and so far so good...no check engine.I added another 5 gallons of gas and the light went out but keeps flashing on from time to time......not a big deal.. as long as it runs.the truck is in very ggod shape and I got it for 1400 cdn.even if I got to put a gran in it I dont mind.im not familiar with auto mechanics...im a snowmobile guy but this forum is really good.......... alot to learn from you guys....thanks again

    ---------- Post added at 09:20 PM ---------- Previous post was at 09:19 PM ----------

    is there a way to post pics without using photobucket?
     
  10. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    The pics can be uploaded from your desktop as well... And as i said to the SeaFoam thing.. That really will help. and at $7USD a can its great stuff....
     

Share This Page