A/C Problems '05 Coly Z85 Model

Discussion in 'Chevy Colorado Forum (GMC Canyon)' started by axlman, Jun 29, 2007.

  1. axlman

    axlman New Member

    Hey all,

    Maybe someone can shine some light on this for me before I take the truck to the dealer.

    As of late, and almost everyday, I've been having A/C problems. Here's what it's doing. I can turn it on to either, 1,2,3,or 4 and it'll blow fine but out of nowhere it will stop blowing all together. But here's the catch, it'll only stop blowing if set on 1,2, or 3 but will blow full blast if I turn it up on # 4.

    I believe that even if I tried turning off the A/C button and changing it to heat it won't blow either. (Not sure, don't remember).

    It's happened at any givin' time,. After starting truck, while driving, etc. Tonight for instance it did it again. When it did start blowing on the lower numbers, it would even stop for a second then start blowing again. I'm lost with it.

    Anyway, I'm trying to hopefully get some insight on the possible problem because I know for a fact that more than likley when I bring it down to the dealer, if they can't replicate the issue they will just tell me that there is nothing wrong even when I know that there is!
     
  2. jhbmf

    jhbmf New Member

    I've got a 2004 Colorado LS that started doing that almost a month ago i guess. It is intermittent, I can't pin point it to anything like leaving the AC on or off or at any particular level, it does it with ac or heat. I assume it is either the fan motor or the switch. I haven't been able to take it in to the dealer because I'm never near the dealer when its doing it.

    Plus sometimes if it starts doing it right away when i get in the truck I can switch it between 3 and 4 real fast and it will start working. This is why I think its the switch. Sometimes though I will mess with it for 20 minutes and get nowhere only to park it and come back 5 minutes later and its working. It is very strange and VERY annoying. If you figure it out let me know and I will do the same (If I ever take it in to have it looked at).

    The last time it did that I tried to pop the dash cover off and look at the switch but it's all clustered in with the other 2 knobs into one unit so I can't investigate a whole lot.
     
  3. axlman

    axlman New Member

    Well, It's the blower motor restister or something like that. Luckily I was able to get my truck to do it when I brought it to the dealer. Just bring it to them and explain what's going on with it. I'm sure they know about it.

    I did not get mine fixed because I just trraded in for a new '07 Silverado
     
  4. WestCoastColy

    WestCoastColy Rockstar ROTM Winner 100 Posts

    It's common on a lot of GM vehicles. It did it on my S10 and WS6. It's the fan/blower speed resister. Speeds 1, 2 & 3 run different OHMs of resistance to lower the fan speed. Number 4 always works because there isn't any resister on that setting. If you're under warranty, the dealer will have you in and out in no time if they are not busy. If you are out of warranty, I believe the part costs $25
     
  5. cmcoram

    cmcoram New Member

    I know this is an older thread, but I was having the same problems, and now it won't blow at all. I've changed the resistor twice. The OEM resistor was burned outm and the first one I installed burned out almost immediately. The connector harness was also burned out. So I replaced the resistor and spliced a new harness in. It still doesn't work. Relay is fine, brand new resistor and connector harness. The only thing left is he blower motor itself. This is extremely frustrating.
     

Share This Page

Newest Gallery Photos