ABS light & Parking Brake light on together?

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by 6camaro9, Jun 11, 2008.

  1. 6camaro9

    6camaro9 New Member

    my ABS and Parking Brake light came on and stayed on for a short trip (< 2 miles) from the store.
    i get home turn off my burb ('01) then start it back up the lights went out just like normal. came
    here did a search (ideas) then took the burb for a little trip and the lights acted normal.
    my question should i be concerned? i would be if the lights came back on but they didn't.

    what to look for? speed sensor, fuse, fluid level (normal), etc.

    thanks...
     
  2. unplugged

    unplugged Epic Member 5+ Years 1000 Posts

    A competent shop should be able to read the stored codes in the ABS control unit. All kinds of sources for an ABS light. Some serious, some are simple. Dirty speed sensor, low battery voltage....the dreaded gremlins! The stored codes should point you in the right direction. It's a good sign that the problem hasn't repeated since the single incident.
     
  3. 6camaro9

    6camaro9 New Member

    well i guess i spoke too soon, after a few days the lights came back on. i guess i'll take it to the dealer to have them look at it. i hope it's not going to be expensive to fix.

    thanks...

    edit: after doing some googling i think it's the EBCM. i think i will try www.modulemaster.com to have the EBCM repaired.
     
    Last edited: Jun 16, 2008
  4. zippy

    zippy Rockstar 100 Posts

    First things first, pull the ABS trouble code and go from there.
    We've all been there... this sounds pretty basic; but, are you sure you had the parking brake fully released before your trip to the store?
     
  5. 6camaro9

    6camaro9 New Member

    follow-up: i sent my EBCM to modulemaster, quick turn around time.
    i reinstalled it and all is good.
     

Share This Page

Newest Gallery Photos